Driver installation failure - possible solutions & discussions page

This page is mainly related to installation problems on Vista, Win7, Win8, Win10 - x64 versions.

Problem description: driver installer hangs and does not finish for minutes or it shows the following message :"Please Plug-in UNi Xonar Audio device!".

Attention: Before trying any of the possible solutions be advised that on Vista, Win7 & Win8 x64 versions the following cards will (in most cases) need test mode enabled in order for the drivers to install:

  • 1.75b, 1.80b - all cards except Xonar STX II
  • 1.70, 1.71, 1.72, 1.75a, 1.80a, 1.81a+  - HDAV(+Slim), Razer Barracuda, Xonar STX II
  • 1.61, 1.62, 1.63, 1.64 -  HDAV(+Slim),Razer Barracuda, HTomega cards, X-Meridian.
  • 1.51-1.53 - HDAV(+Slim), X-Meridian (1,2), HT Omega cards, Razer Barracuda AC-1

Before trying any solutions please uninstall current audio driver and restart.

I recommend you try all the possible solutions presented and not only the last one.

Possible Solution 1 (16.03.2012)

  1. Download the drivers only archive corresponding with the UNi Xonar drivers you wish to install from here.
  2. Unpack the archive, preferably to desktop for ease of use.
  3. Launch Device Manager  (right-click on Computer-> Proprieties and select Device Manager on the left pane)
  4. If the audio card drivers are completely uninstalled, the audio card will show as Multimedia Audio Controller or Unknown device - double click on it .
  5. Go to Driver tab and and click on Update Driver...
  6. Choose "Browse my computer for driver software" and in the next screen select Browse
  7. Within the browse window navigate to the folder where you have extracted the driver archive that you have downloaded and click Ok.
  8. Click next, and wait for the confirmation that the drivers installed correctly.
  9. Close all windows and launch UNi Xonar drivers setup.
  10. Uncheck "Silent installation" and "Run driver cleaning before install" and install the drivers

Possible Solution 2 (14.10.2012)

  1. Start Windows in Safe more by pressing F8 before Windows boot.
  2. Select Safe Mode.
  3. Once Windows boot is complete, install  UNi Xonar drivers.
  4. Restart and boot normally.

Send feedback

Please send feedback if this worked for you or not. Add the following information at the beginning of your feedback comment:

[Possible solution number; Audio card; UNi drivers version tested; Windows version;  SP (0/1/2);  Automatic updates(Y/N); ].

eg: [1; Xonar DX; 1.53;Vista; SP2; Y; ] Your comment..

This page is only for discussing the installation problems and solutions. For general help, comment on the main UNi Xonar page.
Useful for:

  • ASUS Xonar DG, Xonar DGX, Xonar DG SI, Xonar DS, Xonar DSX, Xonar D1, Xonar D2, Xonar DX, Xonar D2X, Xonar HDAV, Xonar HDAV Slim, Xonar Essence ST, Xonar Essence STX, Xonar Essence STX II, Xonar Xense.
  • Other C-media CMI8786 and CMI8788  audio chipset cards:
    • Auzentech: HDA X-Purity 7.1, X-Meridian 1G, X-Meridian 2G.
    • HTOmega: Claro, Claro Plus, Claro II, Claro Halo, eClaro.
    • Razer Barracuda AC-1.
    • TempoTec HIFIER Serenade.
Donation notice
Was this helpful? Please consider supporting us by making a donation.


  1. Suhov31 Oct 2015 @ 10:36

    Hi there!
    I've discovered a problem with 1.80a driver on my Asus Xonar DX. In some cases I can hear a cracking sounds when some low sound is played. It is not heard all the time and looks like it's bound to one specific frequency (waterfall-like sound). It's not loud, more like a echo. For instance, it's almost never heard in DOTA2 but heard frequently in Prison Architect. Adjusting sample rate from 44,1 to 48 both in game options of Prison Architect and driver have changed nothing, so does audio channels option. I've just switched back to 1.75a r2 and problem have gone.


  2. Tom02 Dec 2015 @ 00:43

    My instalation failes no matter what. I'm running in testing version with disabeled signature verification, even tried it in safe mode. Failes every time. There must be something I'm missing. Windows 7 64-bit, Asus Essence STX II.


  3. Axel28 Dec 2015 @ 23:28

    I have tried to install the drivers a few different ways, even tried the stock Asus drivers but my problem still prevails.
    My problem is that every time I try to open the Xonar audio center, it says "Can't find any device" I've done several clean installs, using the number one method etc and still no luck.
    I have an Asus Xonar Essence STX sound card running on windows 10 64 bit. The Uni drivers used to work great, but during some point, I started to get this error code, any fixes for this problem?


    • CarvedInside29 Dec 2015 @ 17:36

      But does the sound playback works? If yes then repost the comment under the main UNi Xonar page since this page is for driver installation problems and not for "Asus Audio Center" or other auxiliary driver components problems.


  4. Duc28 Jul 2016 @ 10:00

    AsusAudioCenter does not show up after installing. UNi Xonar 1822 v1.75a r2 for Asus Xonar Essen ST on Windows 7 x64.


    • CarvedInside28 Jul 2016 @ 15:10

      Did you run the installer or just installed driver only files from "Possible Solution 1" above? If you run the installer, did you choose "Low DPC Latency" or "C-Media Panel" configuration? Look for "Xonar Audio Center" under "Start->All Programs->UNi Xonar". If it's not there look for AsusAudioCenter.exe in "C:\Program Files\UNi Xonar Audio\Customapp". If it's not there either then it's possible the installation failed. You should try installing 1.80a r2 drivers and see if that gives you access to the Asus Audio Center.


  5. Villy17 Aug 2016 @ 11:15

    Hi guys!
    My version of the solution to the problem of Xonar EEPROM failure and the message "Please Plug-in UNi Xonar Audio device!" (for Xonar D1 & Win7 x64)

    I did not help the utility of the "alsa-project" restores the original ID, she could not see my soundcard from under DOS. But the problem was solved by installing a sound card to another PCI slot! After the restart of the system IDs match the original, and I was able to install the UNi Xonar drivers (UNi Xonar 1816/1823 v1.80a r3).


  6. Ricky29 May 2018 @ 10:39


    Not sure if you will respond - but I just bought the Xonar STX II 3 days ago and it's causing my PC to BSOD Constantly, I'm trying to install ur modded drivers but it's not letting me finish the installation process, all I get is this http://prntscr.com/jnxn9y
    I've done the steps to use test mode and use "Disable Driver Sign Enforcement" but it is still not finishing the installation, I have cleaned the device drivers of Asus but nothing works. Running on Safe mode did not help me either.

    Is there anything else I can do?


    • CarvedInside29 May 2018 @ 12:04

      Tell me the OS version and if it's windows 10 which version number. Which UNi Xonar drivers have you tried to install? Have you also tried the 1.80b which do not require Test Mode for your card?
      If you are trying to install v1.81, boot with "Disable Driver Sign Enforcement" and try installing the drivers following the steps from Possible Solution 1 that's been presented above.


      • Ricky29 May 2018 @ 12:45

        I'm on Windows 7 64bit - the latest version of ur driver UNi Xonar 1816/1823 v1.80a r3
        I have not tried 1.80b but also unsure where this is - is it this one? "UNi Xonar STXII 11.5 v1.80b r3"


        • CarvedInside29 May 2018 @ 15:44

          Yes that's the one.


          • Ricky29 May 2018 @ 16:39

            I was able to install it and is working currently - I'm just now hoping these BSOD's don't keep happening.
            This is a crash log from Bluescreenviewer http://prntscr.com/jnztuuhttp
            Might help you idk


          • Ricky30 May 2018 @ 02:06

            Seems after my play-through of Skyrim today (modded) has no longer BSOD's with the soundcard - I really appreciate how effective you've made the fixes on these drivers, thank you.


            • CarvedInside30 May 2018 @ 09:55

              Glad to hear. You're welcome.
              Which drivers you end up installing?


              • Ricky30 May 2018 @ 11:49

                This driver "UNi Xonar STXII 11.5 v1.80b r3" has helped quite a bit with regards to BSOD in games and apps and it seems to remain more stable for a longer duration of time - however I would still need to play with it further to see if it still remains its stability.


  7. Denis01 Aug 2018 @ 03:06

    Thank you man.
    I dont know even how this happend, I updated Corsair CUE today, and my sound card just stopped working, reinstalling the driver/switching PCI-E slots didnt help.
    Download your driver and hope – the sound card works again 🙂
    Thanks buddy!


  8. Meet25 Oct 2018 @ 19:57

    i just update my windows to 1803 and my xonar DG is broke , I tried several things but I did not succeed when installing the driver


    • CarvedInside25 Oct 2018 @ 20:32

      Have you tried the "Possible solution 1" that is presented in the post above? What error do you get?
      Which driver version have you tried to install?


  9. Michael07 Dec 2018 @ 17:56

    Windows 10 1809 tried various driver versions. They all freeze my pc when i try to run the installers. Tried manual driver only install but it doesn't stay when i restart pc.

    The stock ASUS 11.5 drivers install fine but yours are far superior.

    Any help?


    • CarvedInside09 Dec 2018 @ 18:44

      1. You have the STXII card?
      2. Have you tried UNi Xonar v1.80b?
      3. Is it a particular installer step where your PC freezes or it is just after launching the installer?
      4. When the PC is frozen does the Caps Lock key activate the coresponding keyboard led or not?
      5. What security solution do you have installed (Windows Defender, Avast, etc.)?
      6. Did this problem start after updating to windows 1809?


      • Zakk09 Dec 2018 @ 19:05

        I have the STX II with expansion card. 1.80b seems to work ok but isn't this just the stock ASUS drivers? I'd like to try the newest versions.
        The PC freezes completely. I don't use any security except firewall. I think the problem was on prior version of windows too.



        • CarvedInside09 Dec 2018 @ 19:39

          Are you Michael or someone else with the same issue?
          Your current Windows version?
          The audio drivers in v1.80b are the same as ASUS 11.5 drivers.
          Don't think you are missing anything by going with the latest drivers.
          Did you enabled test mode or disabled "Driver Signature Enforcement" before trying to install the drivers? Which one?


          • Michael09 Dec 2018 @ 21:39

            Michael, odd it used my google account for that reply.

            Anyway, I posted a reply to all of your previous questions but it hasn’t shown on here yet. I’m on 1809. the 180b version freezes as well. I did disable sig enforcement and tried test mode, same result.


            • CarvedInside10 Dec 2018 @ 00:05

              Don't know how it used your google credentials with that other reply. Maybe the form was autocompleted on your browser side.
              There is no other comment, something must have went wrong.
              Also, I noticed that the reply button from the e-mail notification does not work, but that does not affect the issues above.

              I'm interested in answers to questions 3 and 4.
              Another thing that might offer some insight into what is going on is the logs in Event Viewer. Type "Event Viewer" in Windows search and launch it, in the left pane go to Windows Logs->Application and check the logs at the time of the PC freeze. Do the same for Windows Logs->System. Warning or Error entries are of particular interest if they exist, but Information entries might also contain useful information.


              • Michael10 Dec 2018 @ 02:07

                I was able to get 1.80b installed and functioning. Had to manually clear out registry entries and all files related to drivers. The 1.81 version still freezes my PC however. In regards to questions 3 & 4, 3 it freezes before the install screen even comes up, and 4 the caps lock key does not work.
                Thank you.


  10. alex16 Oct 2019 @ 13:06

    mine is asus xonar se. recently i discover that the xonar media center doesnt show after some windows 10 pro update, version 1607, 14393.1480. I try installing uni xonar but card not listed. I can use the card base on headphone mode, but i got 5.1 setup and i use 5.1 solely for movies. any of the guru here pls help ~ ~ ~


  11. EvgenKo42312 Oct 2020 @ 18:53

    [-; Xonar D1; 1.80a r3; 7 x64; SP1; N (Windows Update disabled)]
    Was using 1.75a r2 for a long time now and just updated to 1.80a r3. Config: C-Media with GX, cleaning, upmix.
    Previous driver was uninstalled successfully, new device tooltip showed up in tray for a split second and after that installation hang. Looking at Task Manager I've seen drvinst.exe process with no CPU usage and System kernel using 12.5% (1/8 cores full). Both default and alternative installations have failed. Killing drvinst.exe had no effect. Looking at Device Manager I've seen that the driver itself had actually updated successfully, any interaction with a sound card (like trying to disable or looking at Resources tab) caused an mcc deadlock. Reboot had hang as well, so I've done a hard reset. Another reinstall after reboot completed successfully.

    I have a pure Win 7 SP1 x64, no other updates, no antivirus (no viruses either), no firewall, no defender, no other security stuff.


    • CarvedInside13 Oct 2020 @ 09:38

      Did you restart the system after uninstalling the drivers? In UNi Xonar installer, did it show that installation failed? Please explain what you mean by "mcc deadlock"?
      Let me know if you encounter this again in the future.


      • EvgenKo42313 Oct 2020 @ 10:52

        Well, uninstallation was a part of an installation procedure, so no, I didn't reboot directly after uninstallation. But after installation of a new driver had (partly) failed (yes, installer said that) I did reboot.
        Yeah, I mistyped, sorry. I mean MMC Console (which runs Device Manager) hangs forever.


      • EvgenKo42315 Oct 2020 @ 19:19

        Seems like it happens every time if it's not a fresh PC boot (e.g. it's resumed from hibernation).


        • CarvedInside15 Oct 2020 @ 20:08

          If you can try this: after being resumed from hibernation, uninstall the driver from Control Panel-> "Programs and Features" -> "UNi Xonar...". Then try installing the driver again, first time with "Run driver cleaning" and then if it still gets stuck, repeat the steps but install the driver without "Run driver cleaning".

          Some questions:
          1. What motherboard do you have?
          2. Are you using hiberation (your PC will boot again but load things as they where) or standby S3(system is powered down and the wake up to where you left off is almost instant)?
          3. Did you or do you have this problem with v1.75a r2 (or r3)?


          • EvgenKo42316 Oct 2020 @ 17:51

            I'm planing to revert to 1.71 or some older version if white noise issues will still happen regularly as I didn't have it before 1.75. I'll try this when I'll get to it.

            1. ASRock P55M Pro (yes, it's kind of ASUS);
            2. Yes, hibernation. I can't use sleep now cuz it seems like my PSU can't provide stable low voltage anymore...;
            3. I didn't have it before 1.80.


  12. RMLeLoup02 Jun 2022 @ 00:02

    Admin notice: comment moved by admin here.


    • CarvedInside03 Jun 2022 @ 20:11

      This page isn't the place for such a issue. Neither the website's e-mail. I ask you to read the first 2 sentences of this page to see what's it all about, then go to the About/Contact page and read what I wrote there regarding using that e-mail for technical support issues.


  13. Zakkwylde23 Nov 2022 @ 00:34

    I recently upgraded from windows 10 to Windows 11. I am trying to install my STX II. I have put windows into test mode and disabled driver signature enforcement but it still gives me the message that it cannot install due requiring windows to be in test mode or driver signature enforcement. DO you have any advice? I have tried v1.80 and v1.81.

    Thank you.


    • CarvedInside23 Nov 2022 @ 02:17

      Try to install v1.80b which has signed drivers for STX II cards.


      • Zakkwylde23 Nov 2022 @ 02:35

        Hello, thanks for the reply. I tried that one too. Similar message. Here's the entire message for each "Compatible driver was found but it's installation requires windows running in test mode or running with disable driver signature enforcement startup option and that you press 'install this driver anyway' when asked if you want to install this device hardware."
        For 1.80b "Compatible driver was found but it's installation requires that you press "install" when asked if you want to install this device hardware".

        Problem is, the press option never shows for either one.


        • CarvedInside23 Nov 2022 @ 06:03

          1. Is the card correctly detected as STX II by the UNi Xonar installer?
          2. What happens when you try "Possible Solution 1" from the article above?
          3. Run the UNi Xonar installer with right click "Run as administrator".
          4. Tell me your complete Windows 11 version number.


  14. dj623005 Feb 2023 @ 19:04

    When I open execute the install the PC freezes after 3 seconds. I tried with and without test mode. Have anyone else encountered this problem?

    I installed it successfully on my PC earlier before I swapped the motherboard. All other components are the same. I did a fresh Windows install afterwards. The previous motherboard had PCI slot, the new one have added an PCI-E to PCI adapter.



Leave a new commentReply to comment

Comment received.
Your comment may be held for moderation. If it does not show up immediately, please be patient. Comments have to comply with these rules:
  • English language only
  • Don't post insults or threats
  • Try to keep the discussion constructive and informative
  • Don't post questions without doing a search beforehand
  • For replies to individuals regarding the SAME discussion, use Reply to write to that individual. For a NEW issue write a new comment.
  • Make your comment easly readable. Write the product names how they are originally written or at least capitalize their first letter. Write "i" as "I". Add a space after end of a sentence and beginning of another (e.g. ".I" -> ". I").

We've noticed that you're using an AdBlocker

It's not just you, over 66% of our site's visitors are blocking the ads.

Please disable adblock for this website and refresh this page if you:
find the content useful
want us to create more useful content and software
want tech support through the comment section

The ads are placed so that there is minimal interference with page reading. There are no pop-up, pop-under or sticky ads.

Alternatively, you can support us by making a donation.