1. fabulist96120 Mar 2012 @ 02:08

    Hello everyone,

    In 64-bit systems, I always do the following for the drivers to function properly:

    1) Open Command Prompt

    2) Run the following commands:

    bcdedit.exe -set loadoptions DDISABLE_INTEGRITY_CHECKS
    bcdedit.exe -set TESTSIGNING ON
    Bcdedit.exe -set nointegritychecks ON

    3) Restart

    4) Download Driver Signature Enforcement Overrider from here:

    5) You should use the "Sign a System File" function of the program to sign all the drivers found in your Device Manager related to the sound driver -> "Sound, video and game controllers".

    You should be able to see them by right clicking on the driver -> Properties -> Driver tab -> Driver Details.

    Whenever you do not see a certificate next to a driver's element, you should sign it with the software by typing each and every path properly.


    The above method works with all x64 Windows versions, however, Professional and above versions can use alternatives for doing this, which are easier, but I do not remember to list.

    Here’s an example:


    These have to be signed for my “ASUS Xonar Essence STX Audio Device” driver.

    Although disabling integrity checks and enabling “Test Mode” in Windows may result to have your system able of output, not signing the drivers is possible to produce problematic behavior or some functions not to load / work properly.

    Hope this helps!


    • Prophet12 Oct 2012 @ 14:49

      I havent been able to get swap between headphones/speakers (2) to get to work in the last ~version with my stx. Would this fix it?


      • CarvedInside12 Oct 2012 @ 20:39

        Fabulist solution is to no use to your problem.

        For my info, tell me which drivers did you installed 1.62 or 1.63.
        You might want to try switch back to speakers with Front Panel Switcher. Dl on the UNi Xonar page.


        • Prophet12 Oct 2012 @ 20:41

          Thanks for your answer Carved. I have tried them all. The last 3 versions didnt change speaker/headphone for me. I tried that tool you mentioned.


  2. Dave20 Mar 2012 @ 08:22

    1; Xonar Essence ST 1.53; Windows 7 SP2; Y

    Says access is denied when trying to install drivers via device manager.


    • CarvedInside22 Mar 2012 @ 18:56

      You need administrator rights to do it. If you have administator rights , try disabling UAC.


  3. dotslasher24 Mar 2012 @ 12:02

    Xonar Essence STX @ Windows 7 x64

    Installation was successful Test mode is also disabled. So it's all good.
    The signature issue has been resolved.

    thanks alot!


  4. Michael Masterson24 Mar 2012 @ 19:09

    [1; Xonar DG; 1.53;7;Y; ] I always get a prompt to "Please plug in UNi Xonar Audio device!" which gives "Retry" and "Cancel" at what seems to be the last stage of installation. This happened during a normal installation before trying the results up here as well as trying this method.


    • CarvedInside26 Mar 2012 @ 18:39

      Does this happen with 1.41 drivers as well? And if you have time, maybe you can try also installing the 1.53 drivers with "Digital signature bypass .." option checked and windows running with test mode enabled ( you need to restart after you enable test mode ).


  5. Juupeli26 Mar 2012 @ 07:29

    [1; Xonar DG; 1.53;7;SP1;Y; ] Without TESTMODE OFF i get (error code 52 no windows signature drivers) enable TESTMODE no problems. I try like FABULIST961 says but i must leave TESTMODE ON to get drivers working, and right down corner i have watermark "test mode windows7 blaa blaa"


    • CarvedInside26 Mar 2012 @ 19:57

      When you say it worked with test mode on, are you refering only to FABULIST solution or installing Uni Xonar drivers 1.53 with "Digital signature bypass.." option checked?
      Can you also try installing 1.41 drivers?

      You can get rid off the test mode watermark, guide here


  6. Juupeli27 Mar 2012 @ 09:30

    <blockquote cite="#commentbody-4003">
    CarvedInside :
    When you say it worked with test mode on, are you refering only to FABULIST solution or installing Uni Xonar drivers 1.53 with “Digital signature bypass..” option checked?
    Can you also try installing 1.41 drivers?
    You can get rid off the test mode watermark, guide here

    1.41 drivers works without problems.
    1.52 drivers works without problems.
    1.53 drivers is problematic with windows signature...

    installing Uni Xonar drivers 1.53 with “Digital signature bypass..” option checked? YES and enabled test mode. When i take test mode off and reboot "normal mode" no audio cause ERROR 52 no signified audio drivers.


    • CarvedInside27 Mar 2012 @ 13:53

      Have you tried installing 1.53 without "Digital signature bypass" option checked and with test mode off?
      That option is only good with test mode.


  7. Xd27 Mar 2012 @ 22:01

    Ty for the driver man:) your realy good and i wish you best of luck finding a work place that suit your needs.
    I install 1.53 driver for windows 7 32 bit and my problems with 5.1 in games and movies are gone.


  8. Fabulist30 Mar 2012 @ 16:16

    Hello again everyone,

    Some clarifications to what Juupeli said:

    Yes you must leave everything enabled in BCDEDIT even after you have completed installing the drivers and signing them - disabling "Test Mode", and any other BCDEDIT tweak, can cause the drivers to stop functioning again as the 'signing drivers' logic is based on having "Test Mode" left enabled.

    Having that in mind, if however you update your drivers to a new version, you only have to re-sign them as all other tweaks you have made will remain enabled, like the "Test Mode" adjustment.


    Nevertheless, another 'tweak' you can give to your computer to make sure whatever issues you are having (like stuttering) are not driver related; is to remove Windows driver dependencies from audio services:

    Note: This is valid for Windows 7 x32 & x64 versions with or without SP1 - probably Vista too, uncertain for XP.

    1) Go to "Run..." -> usually appears after you press the "Start" button on the lower left corner of your task bar.

    2) Press "Regedit" without the quotation marks, and hit "Enter" on your keyboard.

    3) Navigate to: HKEY_LOCAL_MACHINESYSTEMCurrentControlSetservicesAudioSrv

    4) *OPTIONAL* Backup just in case: right click on the AudioSrv folder looking key you just navigated, select "Export" and save it somewhere with any name you prefer.

    If you mess up, double clicking on the registry key (what you just saved, is a registry key that will appear as a blue like cube breaking) and clicking "Yes" on the confirmation dialogue, will restore the key to what its values were before you edited it.

    5) Double click on "DependOnService" visible on the right side of the window.

    6) Now you should see a window named "Edit Multi-String", delete every value there but "RpcSs". That means that you should be able to see only "RpcSs" after you edited it.

    7) Press "Ok" and restart.

    Audio service dependencies on network throttling and prioritization techniques should be removed now.

    What did I just do?: Find more information about dependencies via Google.com and by reading the "Dependencies" section here: http://www.blackviper.com/windows-services/window...

    The above tweak is preferred by gamers and power users or audiophiles that are having issues with either poor computer performance or incompatible services, it has no side-affects that I am aware off.

    This should further reduce DPC latency in older computers under certain situations, like playing games or multi-tasking (stressing CPU) - but it should make no difference to ASIO playback, meaning; do not expect to see any performance increase with ASIO.

    Hope this further helps people, cheers!


  9. Juupeli01 Apr 2012 @ 15:17

    <blockquote cite="#commentbody-4012">
    CarvedInside :
    Have you tried installing 1.53 without “Digital signature bypass” option checked and with test mode off?
    That option is only good with test mode.

    Tryed but no help. Need to keep using windows 7 test mode enabled.


  10. 1moussaka103 May 2012 @ 23:53

    I have a xonar essence stx and win7pro. I'm trying to install these for the first time and I got test mode enabled and I thought I had the drivers installed, but I have no idea how to get to the cmedia panel. It is no where in the program list and it is no where in the control panel. My little speaker icon in the task bar has a red x on it and the sound isn't working. Also, when it installs and says "Installing, this should not take more than 60 seconds", it takes like 15 minutes and I have an SSD... what am I doing wrong?


    • CarvedInside04 May 2012 @ 17:09

      Did you also check "Digital signature bypass (x64 only,for HDAV & non-Asus cards, test mode has to be enabled)" in the UNi Installer?

      Installation takes this long only when there its a problem, in this cases (when installation is problematic) its better to uncheck the "Silent installation" option in the UNi installer.


  11. shearme04 May 2012 @ 11:28

    [1; Xonar DG; 1.5x, 1.60; 7 64-bit; SP (1); Y; ].

    After manually installing the driver, I tested all the ports (including front audio) and only the rear green port produces audio, which is not stereo. Launching the UNi Xonar drivers setup has never worked; installation never completes or I get a "please insert card" error. Once this point is reached, many of my applications stop working (windows and third party) and ending the process through task manager does not get them working again. No audio comes from any port at this point. Restarting my system seems to fix the freezes in other programs and audio comes out of the green port again.

    I have tried uninstalling from both the device manager, driver sweeper, one after the other, the other after one, restarting and not restarting at various points, but never test mode...

    What Do?


    • CarvedInside04 May 2012 @ 18:23

      Thanks for sharing this.

      In order for the other output ports to work , they need to be activated through Asus Audio Center or Cmedia Panel. This in turn need for UNi Xonar drivers to be successfully installed, which is the problem you have.
      The only thing that comes to mind is to try installing drivers with test mode enabled and the "Digital Signature Bypass" checked in the UNi installer. You can try this without taking in account the steps described in "Possible solution no.1".


  12. shearme04 May 2012 @ 11:49

    <blockquote cite="#commentbody-4360">
    shearme :
    [1; Xonar DG; 1.60 & 1.5x; 7 64-bit; SP 1; Y; ]
    I’ve done everything both correctly and incorrectly numerous times, and the only thing I’ve gotten to work is the green rear port (not stereo). Running the “UNi Xonar drivers setup” leads to many applications (both windows and third party) to not function correctly if at all.
    I told myself I’d go to bed at 2 am and am now pushing 4… what do?

    Ok, so the green port IS stereo, and works in quad, 5.1, and 7.1 as well using the windows sound manager, but still no other ports work nor does the front panel.


  13. pie06 May 2012 @ 01:02

    CarvedInside/UniXonar Team,

    There is something definitely wrong with 1.60, at least installing on an Asus Xonar Essence STX.

    I have tested it on a Windows 7 x64 and Windows 8 Consumer Preview x64 install and both give the same result; no installation.

    1) Installation through the installer with any combination of settings. Test mode enabled with DSEO signing and the following settings does not work:
    bcdedit.exe -set loadoptions DDISABLE_INTEGRITY_CHECKS
    bcdedit.exe -set TESTSIGNING ON
    bcdedit.exe -set nointegritychecks ON

    Regular installation with everything as it would be on your first installation does not work either. Not with compatability mode. Not with anything.

    2) Installation through the driver only method says that there is an error adding the driver to the store. This is the same place that installer installation hangs when you look at the cmd window.

    3) However, using 1.53 works fine on both W7 and W8, with any combination of the above.

    So, 1.60 does appear bugged.


    • CarvedInside07 May 2012 @ 16:39

      It seems you know what you are doing but I have to ask, did you select "Digital Signature bypass.." option in UNi Xonar installer while being in Test mode, and have it uncheck while trying to install without test mode

      For me it works without test mode in Win 7 x64 , but only works with test mode in Win 8 x64. And from the comments others with Win7 x64 and STX installed the drivers without a problem. For you it doesn't work and I am not sure whats happening here.

      Thanks for the feedback.


      • pie08 May 2012 @ 01:19


        I did indeed try installing with the driver signature bypass. This was coupled with Driver Signature Enforcement Overrider, where you would need to sign the files yourself. A couple of installations later and it did actually get past the part where it hangs (driver store) and actually completed setup. I had this happen on Win8 and Win7, and I thought I was done.

        Unfortunately, I had yet another problem. After installation, I wouldn't actually get any sound. The driver was installed correctly (date was 3/11 or something), but no sound would output. So, I would have to use the zip with the driver files only (1.53, as 1.60 gave a driver store error as well) and add it there. Finally, I had sound. However, no ASIO 🙁

        I've since installed a fresh install of Win7 x64 and I think I'll use a PatchGuard disabler and remove the need for signing files completely, just in case. You guys can read about it at http://fyyre.l2-fashion.de.


        • pie08 May 2012 @ 01:56

          I finally got 1.53 to install with the panel. I think I did a partial install then had to remove the driver through the device manager. One last install and it worked.

          I use coaxial, so without it, I can't switch to PCM mode and I won't get any sound. That's why I wouldn't get any sound even if I got the driver to install somehow. This is a problem with Win8 as it has no panel and no easy way to switch for the time being.

          I was able to install 1.60 through the Device Manager through a driver only install after installing 1.53 successfully as using the installer never worked for me.

          Mission accomplished!


  14. Daichi25 May 2012 @ 13:09

    One question 🙂
    Will this 1.60 drivers and future drivers work normaly on Win XP?? Without this test modes and other stuff's??


  15. lesc27 May 2012 @ 13:46

    was able to get control panel to work in windows 8. it's not a software problem but a hardware problem, i changed pci-e slots and i got the uni-xonar control panel to come out.

    i think it also fixed a little problem i'm having with this player of mine.



Leave a new commentReply to comment

Comment received.
Your comment may be held for moderation. If it does not show up immediately, please be patient. Comments have to comply with these rules:
  • English language only
  • Don't post insults or threats
  • Try to keep the discussion constructive and informative
  • Don't post questions without doing a search beforehand
  • For replies to individuals regarding the SAME discussion, use Reply to write to that individual. For a NEW issue write a new comment.
  • Make your comment easly readable. Write the product names how they are originally written or at least capitalize their first letter. Write "i" as "I". Add a space after end of a sentence and beginning of another (e.g. ".I" -> ". I").

We've noticed that you're using an AdBlocker

It's not just you, over 66% of our site's visitors are blocking the ads.

Please disable adblock for this website and refresh this page if you:
find the content useful
want us to create more useful content and software
want tech support through the comment section

The ads are placed so that there is minimal interference with page reading. There are no pop-up, pop-under or sticky ads.

Alternatively, you can support us by making a donation.