1. Ilia13 Apr 2014 @ 11:35

    Man, you are marvelous!
    So please, add that to your FAQ, cause I've spent a lot of time fighting with it
    Thank you!


    • CarvedInside14 Apr 2014 @ 17:17

      Please use the reply function properly. When replying to a existing discussion use reply button floating on the right of the comment you are replying to.
      If you would have fully read my reply to the other guy having problems installing, you would have known what to do: "I don’t know why you have problems installing, maybe you've installed the drivers with the “Digital signature bypass(...)” option checked and that is causing the problems."
      I will do something about that option so people would not be inclined to check it.


  2. kyle29 Jul 2014 @ 02:23

    can you fix the downloads?


    • CarvedInside29 Jul 2014 @ 05:35

      Which ones? From what I can see, they are working.


      • Delbunk09 Aug 2014 @ 02:46

        Possible Solution 1 – 16.03.2012 .
        Download the archive corresponding with the drivers only archive corresponding with the UNi Xonar drivers you wish to install (1.72 drivers ; 1.71 drivers ; 1.70 drivers ; 1.64 drivers ; 1.63 drivers ; 1.62 drivers ; 1.61 drivers ; 1.5x drivers )

        These download links do not work. This happens:

        This XML file does not appear to have any style information associated with it. The document tree is shown below.


        The bucket you are attempting to access must be addressed using the specified endpoint. Please send all future requests to this endpoint.





        • CarvedInside09 Aug 2014 @ 07:56

          Which browser and version do you have? From what country are you accessing the links?
          Here you have alternate download links : 1.72 and 1.64. I think these ones you would be interested in.


  3. Cayne14 Aug 2014 @ 07:50

    [1 and 2; Xonar STX; 1.72; Windows 8.1; Y]:

    Uninstalled the ASUS drivers in prep for UNi Xonar install. The UNi install failed though, and kept giving me the message "Please connect Uni Xonar audio device"or something similiar. The device was connected though, and was working earlier using the ASUS drivers. No worries I thought, i'll just re-install the ASUS drivers for now. This also failed this though giving me an "Uknown error'' message. I now have no drivers and no sound.

    Any ideas on how to solve the device recognition problem that the Uni installer is having? I've tried complete driver sweeps, reboots, both Sultion 1 and 2.



    • CarvedInside14 Aug 2014 @ 10:56

      Check to see if you EEPROM wasn't overwritten. Guide how to do that here.
      See if EEPROM is the issue. You could also try to run Windows in testmode and trying installing drivers then. In testmode try with and without "Driver signature bypass" option check in the UNi Xonar installer.
      If none works, you can try using system restore to get back to the point where sound card drivers worked.

      Hope any of these tips help you.


      • Cayne14 Aug 2014 @ 12:41

        Thanks for the reply.

        I had already checked the EEPROM weren't overwritten, and the Hardware IDs were still correct. I haven't tried testmode, but did try unchecking all options in the UNi installer, to no avail. System restore wouldn't work either as the computer was only set up this morning and hadn't recorded a restoration point yet. Weirdly, the driver which eventually worked was the 1.71 version, but considering the possible instability of this version on Win 8.1 this is only a temp fix. Again, thanks for your help. I'll keep an eye out for UNi updates in the future



        • CarvedInside14 Aug 2014 @ 13:23

          No problem.
          STX driver signature is fine 1.72. I don't see a reason why 1.71 would work and 1.72 won't.
          Another thing you could try: Go to Windows\System32\DriverStore\FileRepository\ and delete any folders that start with XonarSTX. Try installing 1.72 again and make sure you don't check "Digital Signature bypass" option.


          • Cayne14 Aug 2014 @ 13:58

            Thanks. Removed the XonarSTX files in the Windows\System32\DriverStore\FileRepository\ folder, and tried 1.72 again, but still recieve the "Please plug-in UNi Xonar Audio device". Manually installing just the driver doesn't work either, but this time I get a windows message saying that the install cannot continue because "System cannot find path specified".

            I agree there's no reason 1.71 works while 1.72 doesn't, but it just does. I'll keep looking around for solutions.


            • Márcio Oliveira (@MaRcIuPT)12 Nov 2014 @ 14:54

              I have this problem too with latest drivers. I use the xonar dx and is giving me the “Please plug-in UNi Xonar Audio device” error. I will try with another version


              • Cayne12 Nov 2014 @ 23:44

                Let us know how you go. Several months on and I'm still having the same trouble so I've just resigned myself to using 1.71.


                • Márcio Oliveira (@MaRcIuPT)13 Nov 2014 @ 18:15

                  I installed successfully in windows safe mode. (not test mode)


      • Kurogane01 Feb 2015 @ 06:12

        I've the same issue and i have EEPROM problem do i attemp to Restoring the EEPROM? no testmode/safe mode worked


  4. Anton23 Oct 2014 @ 13:25

    I have used these dirvers for years and last week I decied to install the newest drivers with just the C-panel. I did not like it and now I'm not available to get the old Asus panel back. I have driver sweeped and reinstalled the dirvers in all kinds of ways according to the FAQ but with no luck, it's impossible for me to get the old Asus panel back!


    • CarvedInside23 Oct 2014 @ 19:17

      FYI this is not the right page to post this issue. Usually the main page can be used for problems like this one.

      Try deleting these files: C:\Windows\System\Cmicnfgp.ini and C:\Windows\Cmicnfgp.ini.imi and install drivers again. Hope this solves the issue.

      Even in C-Media Panel configuration the Asus Panel is available, you could access it through Start->Programs->UNi Xonar Audio->Xonar Audio Center. So if by any chance the method above does not work, you could add Xonar Audio Center to Startup and remove CmiCnfgp Dynamic library from Start->Run->msconfig->Startup


      • Anton23 Oct 2014 @ 20:48

        Okay, sorry for putting it in the wrong place. 🙁

        However, I kinda followed your advice, I made a shortcut to the Asus Xonar program and put it in autostart and then I hid the C panel.


  5. silajim25 Nov 2014 @ 01:56

    [posted in the wrong topic]
    I have installed this drivers, but since then i have a problem, the sounds has something like micro-cuts, overlapping sound (from the same source) and both together, and it's really annoying, i tried to revert to the ones provided by Asus but the problem persists. I mostly notice it with mpc-hc but it happens with other every played sound. I have an Xonar D1 , what can i do?

    PS: I also tried to clean the drivers and system restore.


    • CarvedInside25 Nov 2014 @ 02:38

      You've commented in the wrong place. You should have commented on the main UNi Xonar page.

      Since original drivers and restoring the your system give the same behavior, your problem does not have anything to do with UNi Xonar drivers that you've installed. There is something else that's changed. Maybe you've updated the MPC-HC, maybe you've changed some settings, maybe the files you play have become corrupted, maybe your hdd is malfunctioning, maybe you have a virus or something. Some thoughts: You should check playing the same files with the onboard audio card. You may want to check your DPC latency. You should check if you have the same problem playing from youtube and from a memory stick or CD/DVD.


      • silajim26 Nov 2014 @ 18:26

        I am sorry for commenting in the wrong place, the problem was the HDD driver finally, it had very high latency.


  6. Andrew22 Feb 2015 @ 16:47

    Xonar DG SI, Win8.1, managed to install driver only using method 1 and test mod, but still unable to install uni driver and c-panel and stuff. In Devices my card lists as Asus Xonar DG Audio Device (not SI). Hardware ID is PCI\VEN_13F6&DEV_8788&SUBSYS_84651041. Also I can see green line of sound level is moving up and down, in my taskbar, but there's no sound in my speakers. Any tips?

    *update* Looks like method 1 only worked because i messed up with Drivers Only files. I’ve created a new copy of XonarDG.INF file and changed %CMI8788.DeviceDesc%=CMPCIX64, PCI\VEN_13F6&DEV_8788&SUBSYS_84671043 to match my hardware id. When I’m trying to install UNI drivers I’m still getting Please Plug-in UNi Xonar Audio device. I just feel that my hardware id is wrong, but I’m not sure if it’s an infamous EEPROM failure, since my card isn’t listed here: http://www.alsa-project.org/main/index.php/Xonar_EEPROM_Failure


    • CarvedInside22 Feb 2015 @ 17:56

      Please use the reply button properly. When replying to an existing discussion use reply button floating on the right of the comment you are replying to.
      If you are using a NoScript browser addon then you should disable it so that “reply to discussion” button works correctly. I'm making this remark because you've used the "new" reply button when you've made the update post.

      Your card's EEPROM was overwritten, the correct ID for DG SI is "PCI\VEN_13F6&DEV_8788&SUBSYS_855E1043".
      DG SI is a slightly newer card than the rest and either wasn't included in the EEPROM restore tool or the author forgot to include it in the table. You should check the tool, if it does not work then contact the author and forward him the DG SI correct ID.


      • Andrew22 Feb 2015 @ 18:37

        Thank you for the fast reply. I've tried EEPROM fix and DG SI indeed was missing from the list of available cards, so I picked DG one and it works perfectly! I'll contact tool author and ask him to add my card to supported list. Thank you for your help, I'm so happy now 🙂


        • CarvedInside22 Feb 2015 @ 20:41

          Glad I could help. I've sent a e-mail to the EEPROM tool author with the missing DG SI and STX II IDs, so don't think there is a need for you to contact him too.


  7. Al10 May 2015 @ 17:25


    I've been having problems installing the drivers for my essence stx sound card on windows 7 64 bit.I did however successfully install them using your safemode method,but starting to get bsods and hangs.What i have done is just installed the driver package only ,using solution one and not installing the control panel.I'm only interest in the spdif out on this card to my peachtree preamplifier.The sound seems to be working just fine,should i try and get the panel working or is that unnecessary for what i use this card for? Just wondering if i'm missing out on something by not installing the whole package.


    • CarvedInside10 May 2015 @ 21:17

      When you got the BSODs maybe you had enabled GX and that was why you got them. You could install the drivers and select "Low DPC Latency" panel configuration, this will take care of GX. I would recommend installing the drivers from the whole package because when installing driver only the settings are not configured optimally and you are missing some components like ASIO and OpenAL.


      • Al10 May 2015 @ 22:21

        Thank you for the response CarvedInside.

        I just did as you suggested and installed the Drivers with the low DPC Latency option. So far so good,will report back if i get any future BDODs.


  8. Adam17 Jun 2015 @ 20:43

    Hi!! I always enjoyed unixonar, but now without reason my D2 stopped working.
    I found my EEPROM got overwritted but restoreeee didn't work to me. It's says: device not founded
    PCI\VEN_1376&DEV_8788&SUBSYS_82291043 My device id
    PCI\VEN_13F6&DEV_8788&SUBSYS_82291043 A good D2
    As you can see the VEN part is wrong. How can i fix this?

    Thanks in advance!


    • CarvedInside20 Jun 2015 @ 00:45

      Hi. If your card is under warranty I think it would be better to RMA it. If it's not, you can try and contact the maker of Xonar Restore EEPROM tool and ask him if he can modify the tool so it will correct the VEN id.

      What I can do is offer you a modified d2 inf file that could help you install the drivers. It may require that you install with Windows in Test Mode. It may not work at all. I don't think any Xonar audio panel will work with it so you woudn't be able to the card's settings directly. For instructions on how to use it see "How to install addon packs" section from this page.


  9. Danial29 Jun 2015 @ 00:34

    Hi, is it possible for my hardware id to change a single bit in the SUBSYS? I have the Xonar D1 and below is a copy of my HardwareID screen:


    The Xonar D1, according the the EEPROM fix page, should have an F instead of a B in the SUBSYS value. This leads to the audio card not being detected by the Uni installer and the EEPROM fixer (restoreee) does not work. If I edit my registry to update the B -> F the installer runs but hangs.

    Any ideas?


    • CarvedInside29 Jun 2015 @ 20:17

      PCI\VEN_13F6&DEV_8788&SUBSYS_834F1043 is the only valid Xonar D1 HarwareID. In your case restoree.exe should work if you've followed the steps properly. If your card still has warranty you could RMA it.

      The only thing I can help you with is providing you a modified D1 inf file that should allow you to install the driver. It may require that you install with Windows in Test Mode. It may not work at all. I don't think any Xonar audio panel will work with it so you wouldn't be able to the card's settings directly. For instructions on how to use it see "How to install addon packs" section from this page.


      • Danial05 Jul 2015 @ 23:12

        In restoree it finds the card, but at the end I get the messages in this order "invalid; this means that the subsystem ID is ignored", "EEPROM timeout", "It looks as if your EEPROM chip is broken."

        I will give the modified D1 inf file a shot, thank you!


  10. SME03 Jul 2015 @ 06:14

    Was thrilled to find this site, and then the Barracuda ate my enthusiasm.

    I have the Razer Barracuda AC-1 on Win 7. History:
    1. Installed Razer drivers, but the app crashes as soon as I changed the volume with a "CmiCnfg MFC Application has stopped working". Also, the Razer app would start, but never actually show up as a window - I could kill from the app list.

    2. Uninstalled Razer drivers and everything worked (for years). Have an optical cable out to a Pioneer HTS-GS1.

    3. Needed headphones, so reinstalled the drivers and uninstalled / disabled pretty much everything else to see if I could get it to work, thinking I had a conflict. No joy.

    4. Uninstalled Razer, and now only get stereo sound.

    5. Installed UNi Xonar and... the application will not startup. It jumps into the task list and bails out without error. Speaker setup for C-Media only gives stereo. Test "Failed to play test tone." without even trying. Speakers through AC-1 card only work through the headphones (yea!), but can't get SPDIF through the optical.

    6. Running it Test Mode. Tried all three installs. After uninstall from Safe Mode. Installed drivers only in Safe Mode. SPDIF is now working again.

    Should I try a 1.72 install to try to get headphones / app working? Or is it something about the Razer card? I didn't see it in the search, and Razer is stumped with it's software/drivers as well.


    • CarvedInside03 Jul 2015 @ 23:17

      I think you should be able to switch between SPDIF and analog output on your card. Which driver version have you tried to install? It is possible that newer drivers have a incomplete support for Razer Barracuda AC-1. You should try different versions like v1.70, v1.64, v1.54. When installing the drivers for Barracuda AC-1 you should select Low DPC Latency or C-Media Panel and always launch C-Media Panel for controlling the card since ASUS Audio Center will not work on your card.


      • SME08 Jul 2015 @ 03:03

        I ended up with the 1.72 drivers only - no app. Analog gives me the headphone for 1 sec then switches over to the speakers, trying to emulate 5.1, but sounding like crap. When I go back to Digital Output, it only gets stereo until a reboot. I'll try other versions to see what works.


  11. Eric B.05 Aug 2015 @ 11:47

    [1; asus xonar essence stx; 1.75b-STXII-driver-only.7z; Windows 10; Y; ]

    I did this:
    0. download 1.75b-STXII-driver-only.7z; unpack
    1. go to Device Manager
    2. update driver software for audio device
    3. result:

    Windows found driver software for your device but encountered an error while attempting to install it.

    ASUS Xonar Essence STX Audio Device

    The hash for the file is not present in the specified catalog file. The file is likely corrupt or the victim of tampering."


    • CarvedInside05 Aug 2015 @ 15:33

      1.75b STXII drivers require Test Mode in order to work for non STXII cards. I've written about it in the 1.75 driver release notes.


  12. Maurice07 Aug 2015 @ 20:45

    I also had the ”Please Plug-in (UNi) Xonar Audio device!” message with both the Asus original and your 1.75a driver. Turned out it was the Realtek driver that i had still installed that was conflicting with the new Xonar driver installation. Didn't think that would be necessary, but after uninstalling Realtek and rebooting, the new driver installed fine. 🙂

    So this could be Possible Solution 3


    • CarvedInside07 Aug 2015 @ 22:17

      Thanks for sharing. Before uninstalling the Realtek drivers have you tried any of the possible solution above?


  13. Fabian Witkowski11 Aug 2015 @ 22:46

    Dear CarvedInside,

    I have a wierd issue which I need help with, I downloaded the driver: UNi Xonar STX II 11.5 v1.75b r2 as I have a STX II 7.1. But i cannot get 5.1 to work propertly!

    I have an analog connection to my speakers, i cannot choose 5.1 inside the C-media Panel it only shows 6 speakers. But when I press on the speakers under Outout Device i'm getting sound correctly as if my 5.1 actually works. But any windows sound, any game that i start only have sound in the front speakers L + C + R and the quality is soooo bad, the sub does not react at all.

    Is here anything i can do? Please let me know!


    • CarvedInside12 Aug 2015 @ 00:12

      This section is for driver installation problems. For general help use the main UNi Xonar page next time!

      Maybe on Win10 STXII C-Media Panel is missing another option as you have to set speakers and also the number of channels. I will have to check that.
      How about setting the 5.1 speakers with Asus Audio Center or Xonar Switch?


      • Michael16 Nov 2017 @ 03:10

        I need help please..!!!! I need eeprom code for asus STXII please its not on list overwritten and id won't load


  14. Fabian Witkowski12 Aug 2015 @ 07:42

    I triede to do so with the Asus Audio Center too and it's the same problem. All test works in 5.1 but as soon as i start a app or a game i hear a crackeling sound in the speaker as something is changing settings and the 5.1 gets "disabled" and the sound quality is poorer then a speaker for 5 euros


    • CarvedInside12 Aug 2015 @ 12:38

      Please use the reply button properly. When replying to an existing discussion use reply button floating on the right of the comment you are replying to. Since I can’t move the comments please remake the comment with reply and I will delete this separate comment.


      • Fabian Witkowski12 Aug 2015 @ 19:55

        Fabian Witkowski 12 Aug 2015 @ 07:42 – From the section for driver installation problems.

        I triede to do so with the Asus Audio Center too and it’s the same problem. All test works in 5.1 but as soon as i start a app or a game i hear a crackeling sound in the speaker as something is changing settings and the 5.1 gets “disabled” and the sound quality is poorer then a speaker for 5 euros


        • CarvedInside13 Aug 2015 @ 01:37

          You've replied to the wrong comment.This is the comment I've asked you to reply to. It's the the comment where I've said:
          "Maybe on Win10 STXII C-Media Panel is missing another option as you have to set speakers and also the number of channels. I will have to check that.
          How about setting the 5.1 speakers with Asus Audio Center or Xonar Switch?"


  15. Vishwesh19 Aug 2015 @ 20:57

    I'm also facing this "Please Plug-in UNi Xonar Audio device" problem since I upgraded to Win 10 Pro, but only when I try to install DHT addon. Drivers themselves install without any problem. I've been using DHT on Win 7 since I've fount it here and want to keep using it in Win 10, but it keeps giving me above error. I've already tried both the solutions above but without success. So do you have any other suggestions? My card is Xonar DG.


    • CarvedInside20 Aug 2015 @ 03:27

      You've installed the 64 bit Windows 10 right? If that true then the issue is with the fact the driver files are altered when you apply the DHT addon and Windows won't allow the drivers to install. You need to enable Windows Test Mode or install drivers with Windows booted with "Disable driver signature enforcement" option. Info here.

      BTW, which drivers have you installed? Because v1.75 should show a warning when applying addons that would change driver files.


      • Vishwesh20 Aug 2015 @ 10:40

        Oh sorry, I should've mentioned this in initial post. Yes, 64 bit Win 10 Pro, latest 1.75a r2 drivers with test mode enabled. I have been using these drivers on Win 7 x64 for months, so I'm kinda familiar with the process. I also tried this UNi Xonar 1822 v1.72 (DHTv2).exe posted by cracrayol. I tried it with 'Digital signature bypass' enabled [test mode was already on] but result were same as before. So I think I've tried almost everything but haven't been able to use DHT successfully. I use DHT mainly for Intelligent Equalizer and Volume Leveler, which gives nice, consistent volume and keeps it from distorting. So as a last resort, I'm using on-board Realtek with Loudness Equalization enabled, which kinda does the same thing, but not with the same finesse as the DHT. I have to turn if off every time I listen to music, which I didn't need to with DHT.


        • CarvedInside21 Aug 2015 @ 07:39

          Strange. I will have to check things out and see what the deal is.


          • Vishwesh21 Aug 2015 @ 12:29

            Thanks. I can't recall with 100% certainty, but I think it was working when I upgraded the OS. But for some reason (I think volume was lower than Win 7) I removed the drivers, thinking that reinstall will fix it and since then this problem started happening.


          • Vishwesh03 Sep 2015 @ 20:46

            Found the solution. Used UNi Xonar 1822 v1.72 (DHTv2).exe posted by cracrayol but this time I did not select the last option 'Apply addons'. DHT installed without any issue, but it wasn't having any effect on audio. So I searched around and found this registry tweak. Add "DisableProtectedAudioDG" = dword:00000001" to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Audio. Reboot and DHT was working again!! 🙂



Leave a new commentReply to comment

Comment received.
Your comment may be held for moderation. If it does not show up immediately, please be patient. Comments have to comply with these rules:
  • English language only
  • Don't post insults or threats
  • Try to keep the discussion constructive and informative
  • Don't post questions without doing a search beforehand

We've noticed that you're using an AdBlocker

It's not just you, over 66% of our site's visitors are blocking the ads.

Please disable adblock for this website and refresh this page if you:
find the content useful
want us to create more useful content and software
want tech support through the comment section

The ads are placed so that there is minimal interference with page reading. There are no pop-up, pop-under or sticky ads.

Alternatively, you can support us by making a donation.