1. Myk10 Oct 2012 @ 01:42

    Downloaded, and installed the x64 version. At the end, there's an error: "There was a problem starting C:WindowsSyswow64cmicnfgp.dll" The specified module could not be found."
    Same dll is missing when I tried the x86 version.

    Thanks for your patience Carved.


  2. Myk10 Oct 2012 @ 17:31

    Hey Carved, tried the new installer, had the same error message. Copied the cmicnfgp.dll to the path and ran the .bat file as administrator off the bat. Seems like it's not copying the files like it's supposed to. went to C:Program Files... where the asus control panel should be installed and it's not there, checked my Program Files x86 and it's not there also. Ran cmedia.bat after the install.bat as admin, cmd pops up but nothing happens also.

    Is there something I'm doing wrong here?
    Thanks for your patience and time Carved.


    • CarvedInside10 Oct 2012 @ 18:43

      I don't know whats going on and why it does not copy the files for you. I don't see any reason why this should not work.
      Open the install .bat with notepad and use it as reference to copy the files manually. The left is the location of the file you will copy and the right is where to copy it.


      • Myk11 Oct 2012 @ 03:05

        Hey Carved, copied those dlls/cpls/inis to the right directories. Didn't know what to do with the regsvr32.exe so i left it alone and decided to open the Asus Audio Panel...and it worked!

        Do I stop here and just leave the regsvr32 alone?


  3. OVerLoRDI12 Oct 2012 @ 06:30

    Latest UNi Xonar won't actually install on my machine. I select my card (STX) I clean out all the drivers (the little drivercleaner.bat says none of the ASUS driver files found). Then I get the window that says "Installing UNi Xonar Audio Driver....." The blue bar then slowly and consistently ticks along until it is full and it just sits there. Eventually it tells me to "plug in" a Xonar drive and whether or not I want to retry, the sound card is definitely plugged in, it is internal.

    Windows 7 x64
    Test mode enabled
    Asus Xonar Essence STX

    Anything I'm missing?


    • CarvedInside12 Oct 2012 @ 18:46

      Try installing with Digital signature bypass if you enabled Test mode. Try with installing following the steps in possible solution 1. Try an older version like 1.62.

      Did you had any other version of UNi Xonar drivers installed before?


  4. nebulaw14 Oct 2012 @ 01:25

    I've had a Xonar DG and recently upgraded to a Xonar DX. I have never gotten the UNi Xonar drivers (1.5x or 1.6x) to install correctly. I am running Win 7 x64 SP1. To be fair, I haven't really been trying very hard; I've just been running the install with a normal bootup and driving signing enabled. Furthermore, the official Asus drivers have only been slightly more successful at installation and on some freak occasion install correctly. Both UNi Xonar and Asus drivers have either taken a really long time to install and eventually giving me the "plug in" error message. In the device manager the Xonar is installed, but there no control panel on the next bootup and Xonar selections in playback/record devices (thus no sound) on the next bootup after install.

    I really wanted to try the UNi Xonar drivers or at least get more updated Asus drivers, so today I was feeling a little adventurous. I was about to give test mode a shot (even though I don't really want to run my system like that permanently). For the heck of it, I decided to bootup in SAFE mode (hit F8 on bootup and you can choose it from a list). To my surprise, the UNi Xonar drivers installed flawlessly! It didn't take more than 20 seconds on my system (as opposed to my previous attempts where it hangs for a while before giving me a "plug in a Xonar device" message and not working).

    The TL;DR summary is I had success installing the UNi Xonar drivers in SAFE mode when I have been having problems installing in my normal bootup. I would assume this would have also fixed my official Asus driver install problems, though I haven't tried since I got the UNi Xonar drivers working. I assume having success in SAFE mode means that I had some software or OS conflict with the Xonar installer. I am quite happy I got new Xonar drivers installed without using test mode and disabling driver signing.


    • CarvedInside14 Oct 2012 @ 17:18

      Interesting solution, although I find it strange that with normal startup drivers didn't install but they worked in Safe mode. I may post the Safe mode as a Possible Solution 2. Thank you for sharing.


      • nebulaw15 Oct 2012 @ 06:07

        Yes, I thought it was strange too. I haven't done a clean install of Win 7 since it was released a few years ago, so that could be part of my problem. I haven't had any other problems with my PC though. I hope this helps some people get their sound card running. I like the sound quality of Xonars a lot and my only complaint is the unsuccessful driver install process.

        Upon further thought, one common thread I've had with successful driver installs is having no other audio devices installed. I have Realtek integrated in my motherboard and also AMD Radeon HDMI output. The Realtek is easily disabled in my BIOS, but the HDMI output was kind of tricky to disable in my normal bootup since it keeps on reinstalling automatically. I didn't really think of this when doing my previous installs, so disabling/removing other audio devices (and making sure they stay that way) before running the Xonar driver installer might be something else to try. I noticed SAFE mode disables the audio service and all audio devices so that might be why it works for me.

        I should also note for anyone interested that after I get the Xonar installed, I can enable/install Realtek and HDMI audio drivers afterwards and use those devices too while the Xonar is installed though I typically don't. I use the HDMI sparingly for when I run something on my TV and as for the onboard Realtek, I wanted to do a quick A/B comparison of onboard vs Xonar. I had also hoped to perhaps use the onboard for line-in/mic-in since there is only one combined port on the Xonar DX, but it is way to noisy for my taste.


        • CarvedInside16 Oct 2012 @ 18:51

          You could be on something here. When and if you will install new Xonar drivers and have a chance to explore this further let us know if you find anything. HDMI audio component can be disabled from device manager, but don't know if this will keep it out of the way.


  5. nebulaw24 Oct 2012 @ 23:37

    Today I decided to test out if I only needed to disable my HDMI audio output instead of running in safe mode when installing either the official Asus drivers or the UNi Xonar drivers. I tested the 1794 Asus drivers and the 1.63 UNI Xonar drivers (normal Asus control panel since I need easy headphone switching). I also ran Driver Fusion in between install attempts.

    I disabled my HDMI audio output in Device manager. I have previously tried uninstalling it but since it is part of my video card, it always re-installs itself automatically. I then tried to install the Asus drivers and the install failed (took a while for the progress bar to fill up and hung). I removed the remnants of the install, rebooted, etc. and then tried under the same conditions with the UNi Xonar drivers. The UNi Xonar drivers also failed to install correctly (same problem, slow install and hang).

    I then tried the safe mode method again with the 1.63 UNi Xonar drivers. Once again, it was successful on the first attempt. I timed the install this time and it took approximately 12 seconds to reach completion and the restart prompt.

    So, at least for me, installation in safe mode is my best bet. I can't really think of a reason why I wouldn't be able to install drivers in my normal bootup and now I'm really puzzled as to how I previously installed the Asus drivers in my normal bootup. Oh well, at least I have a reasonably reliable workaround that works for me and perhaps someone can take what I found and figure it out.


    • CarvedInside25 Oct 2012 @ 11:15

      I see, really strange. I would lose any sleep over this, while it doesn't exactly make sense why drivers would install (now) only in safe mode. At least it works đŸ™‚

      Good job on this and thanks for sharing.


  6. Johannes29 Oct 2012 @ 20:34

    I'm having trouble getting my XONAR HDAV SLIM to work with my freshly installed Windows 8: The device only works when enabling the "Test mode" setting in the boot up menu. This effectively disables the Windows 8 driver enforcement and enables the soundcard to work.
    With driver signature enforcement the card is listed with error code 52 in the device manager.

    Since there is / does not seem to be a permanent way to disable drive signature enforcement in Windows 8 I always have to boot my computer twice to use the sound. Not so great. Is there any solution in sight?

    Thanks for the, apart from that issue, amazing driver software!


    • CarvedInside29 Oct 2012 @ 20:43

      Driver enforcement and Test mode are 2 separate options. Follow the guide here on how to enable Test mode, this with work every time, at least it did for me when testing the unsigned drivers with test mode.


      • Johannes29 Oct 2012 @ 20:51

        Thanks, I executed the script, though I think I did so before already - but don't know if I had the test mode enabled or not. I will keep you posted if the problem persists đŸ™‚


  7. SlackerITGuy09 Dec 2012 @ 20:04

    I've been having BSODs issues with this latest set, my computer BSODes and then my sound card won't work in the following restart, I have to power off my PC completely and then boot it back up. Any solutions to this?

    I used the low DPC latency option, my card is an ASUS Xonar DS. Specs:

    Intel Core i5-2500K
    ASUS P8P67
    EVGA GeForce GTX 670 FTW
    8GB Corsair Vengeance RAM
    Plextor M3 Pro 128GB
    Windows 8 Pro
    Corsair TX950W


    • CarvedInside10 Dec 2012 @ 03:27

      Try doing a driver clean like its detailed in the FAQ. Install the drivers, you could try 1.63 instead of 1.64.


  8. roma10 Dec 2012 @ 22:08

    which driver you need to install XONAR HDAV


    • CarvedInside11 Dec 2012 @ 16:10

      First you have to enable windows test mode, and when installing the drivers select (Digital signature bypass). Any of the drivers work.


  9. pepelasal12 Dec 2012 @ 21:58

    kb2753842 problems with drivers Uni Xonar


  10. joe26 Dec 2012 @ 16:28

    hey sir this driver is great work than garbage driver ass sus doing..
    btw i have a problem, actualy i just change audio system with av receiver and update driver to 1.64. when i change setting set default to s/pdif pass trough on playback device it become bsod.. before i change my system the driver work fine...oh yeah my sc is d2x. and my os windows 7.


    • CarvedInside26 Dec 2012 @ 16:42

      Try doing a driver clean like its presented in the FAQ and install the drivers again. Also you might want to try different versions (check 1.54 and 1.63).

      Btw this page is for discussions regarding driver installation problems. Use main UNi Xonar page next time.


      • joe26 Dec 2012 @ 22:27

        splendiidd!!! after clean install and try, driver 1.63. is work like a charm!!
        oh, im sorry i didnt realise i post in this page must be in hurry and depresed because bsod stuff.
        thank you for your work sir and have a happy new year!!!


  11. come2me31 Dec 2012 @ 11:23

    Hi all,

    i have a xonar hdav deluxe with h6 extension card, will i be able to use these drivers for my card ? I didn't see this extension card on the list of supported hardware...

    Thanks for your answer.


    • CarvedInside31 Dec 2012 @ 16:11

      I think it should work.

      If you have a x64 OS, you will need to enable Test mode and select "Digital signature bypass" in the UNi Xonar driver installer in order for the drivers to install and work.


  12. Paul17 Jan 2013 @ 22:27

    [1; Xonar DX; 1.64;Windows 7 x64; Y; ]

    I tried to install it in testmode. It did work until I disabled the testmode again, because of Code 52 error... Installing the driver via solution 1 kept the Code 52 error, so I guess installing the driver again wont help...


    • CarvedInside18 Jan 2013 @ 13:30

      Try installing drivers in safe mode and without test mode on and with "Digital signature bypass" option selected.


  13. Harry02 Feb 2013 @ 06:53

    Thank you! That worked fine with drivers 1.63.


  14. Mic04 Apr 2013 @ 20:31

    Hi, it's very cool to continue to work at the evolution of the driver; BUT it also important to install this normaly... this shit is borred to try to install and find information...

    Fuck Asus, Fuck Electronic Arts and fuck all capitalism !! Need to be an informaticien to play or install something !!


    • CarvedInside06 Apr 2013 @ 00:41

      Can you submit some information on your installation problem. Which OS do you have, card, what error you've received in the installer, which possible fix worked for you?


  15. pepelasal22 May 2013 @ 18:18

    How to I turn off digital signature?


    If no signed driver exists, and you are aware of the risks in using unsigned drivers, (accepting responsibility for any problems it causes,) there is a Policy setting available to turn off the requirement.
    Click start, and type gpedit.msc
    ENABLE the option for code signed drivers at:
    User Config/Admin Templ./System/Driver installation
    then set the drop box to "Ignore"


    • CarvedInside22 May 2013 @ 18:53

      Did this worked for you on Win7 x64? It shows that the supported OS for this option are XP and 2003 Server , and from what I can remember when I've tested this it did not work on Win7 x64.



Leave a new commentReply to comment

Comment received.
Your comment may be held for moderation. If it does not show up immediately, please be patient. Comments have to comply with these rules:
  • English language only
  • Don't post insults or threats
  • Try to keep the discussion constructive and informative
  • Don't post questions without doing a search beforehand

We've noticed that you're using an AdBlocker

It's not just you, over 66% of our site's visitors are blocking the ads.

Please disable adblock for this website and refresh this page if you:
find the content useful
want us to create more useful content and software
want tech support through the comment section

The ads are placed so that there is minimal interference with page reading. There are no pop-up, pop-under or sticky ads.

Alternatively, you can support us by making a donation.