1. RomBazz08 Sep 2019 @ 19:55

    Xonar Essence STX.
    Works on MSI B350 Tomahawk, Ryzen 5 1600+, Win10 x64 all from 1709 to latest 1903. Installed driver - UNi Xonar 1825 v1.81a r2


  2. Malix17 Sep 2019 @ 21:24

    Xonar Essence STX, seemingly works perfectly on Asus ROG Strix X570-F Gaming, R9 3900x, Win10 1903, v1.80a r3 drivers


  3. boombastik21 Sep 2019 @ 04:00

    You both have stx that have plx bridge. The problem is cards with asmedia bridge. Asmedia is an integrated circuit design company owned by Asus.


  4. DonPromillo21 Sep 2019 @ 18:51

    Xonar Essence STX, works with ASUS ROG Strix X470 F Gaming.
    Win 10 1903 Uni Xonar v1.80a r3 driver


    • CarvedInside21 Sep 2019 @ 22:18

      Thank you for the information.


      • DonPromillo10 Nov 2019 @ 13:11

        I have a qestion...

        If i have installed my STX (1) on my Board (ASUS X470 F Gaming) my PC start 2 times (only on coldboot).

        (Pc starts, after 1 second it turns off and reboot self after 2 seconds)

        If i have the Soundcard not installed the PC coldboot is fine...

        Is this normal ?, becouse i think it can be the plx pcie bridge


        • CarvedInside11 Nov 2019 @ 19:14

          It's an issue with the motherboard probably when there are other PCI-e devices plugged in. You could contact ASUS support to let them know of the problem.


          • DonPromillo12 Nov 2019 @ 22:18

            but it is only if i pull the plug from the system, its only the coldboot... after this the system always start without a "break"


  5. helge21 Sep 2019 @ 19:00

    Gigabyte X470 AORUS ULTRA GAMING (rev. 1.0)
    R7 2700x
    Asus Xonar D2X
    latest unixfi drivers
    Windows 10 LTSC 1809, Windows 10 1903

    => Instant reboot after playing audio. If i play audio right after reboot and continue to do so, pc keeps running. If you leave it alone and don't play audio - 99% of the time system hard resets. I am also missing the click of the relay, which the card does on every powercycle, after waking the card up from possible idle (long time no audio)

    can get quite frustrating if you forget that and "just want to turn on some music" and all your vms and open work just closes out of nowhere... Did i mention to better disable all windows sounds? An error sound could crash your pc 😀


    • CarvedInside21 Sep 2019 @ 21:50

      Thank you for the info. If you can, please take a screenshot of devices and their IRQ (guide here) and send it to me via e-mail or upload it somewhere(imgur,imgbb, etc.). Only those (PCI) entries are important and make sure that all (PCI) entries are included in the screenshot.

      Have you tried any of the possible solutions presented in the post above?


      • helge24 Sep 2019 @ 02:33

        Hi CarvedInside,

        tried all solutions i found on the internet, including yours 🙂
        Here is the requested IRQ pic. The card works best in second pcie x16 slot. IRQ is not shared.

        ATM it seems pretty stable. I am on vacation the next days, maybe i'll remember to get back here and post my current bios config.
        Last changes i did:
        – changing the psu settings from auto to "new model psu".
        – Turned of XMP (3000MHz) to custom 2933 Mhz ram clock.
        – SMT and SVM still active as i need these features.
        – onboard sound is disabled.
        – HPET active as my applications perform way better with it enabled.
        – Forcing a specific PCIe version made it worse so its back to auto.
        – F42 BIOS too bad they removed PCie v4 support in this version – but with this kind of issues you update and hope for the best 😛


        • CarvedInside26 Sep 2019 @ 01:52

          Thank you. Which UNi Xonar driver version you have now installed? If it's v1.71.1, could this be what resolved or mitigated the issues?
          Any information that might be helpful for others is welcomed.


          • helge27 Jan 2020 @ 20:44

            Much better with latest BIOS and ASIO 24bit (instead of 32bit)with 20ms Delay. Dunno

            BIOS update info:
            Update AMD AGESA B
            Improve system boot time
            Improve RAID function compatibility
            Improve PCIe device compatibility


  6. Sascha29 Sep 2019 @ 13:11

    I'm using a "ASUS ROG STRIX x570-E Gaming"-Board with a Ryzen 9 3900x and installing my good old Xonar D2X in a PCIe-x1 Slot always results in an instant reboot at the drivers installation (1825 v1.81a r2).
    Except when I put it in the second PCIe-x16 Slot. It works there but then my Graphics Card runs only at PCIe-x8. So that's not really a solution for me. Putting it in the third long PCIe (4x, 2x) is stopping the pc from booting at all.
    I hope this won't be the end of the D2X, I got it for nearly 10 years. using onboard meanwhile, which is not even remotely as good.


    • CarvedInside29 Sep 2019 @ 22:51

      Thank you for the information. According to these benchmarks you would only lose about 2-3% on a RTX 2080Ti when going in a PCIe 3.0 x8, lower performance cards than that will lose even less. I think it's definitely worth it if you can still use the Xonar D2X that way.


      • Sascha30 Sep 2019 @ 07:56

        I did exactly that after 2 days of onboard sound. It's so good to hear the familiar quality again. And of course you are right and I knew that I would not notice a difference in performance in everyday situations....it's just an itch in my brain. I just upgraded my pc after 10 years and now I can't use it at peak efficiency. that's somehow very annoying to me and I think about updating my soundcard too. I guess hoping for a bios / software fix is not really fruitful? But where would I go? I still need analog 5.1 output.
        Well. For now it is working.


        • CarvedInside04 Oct 2019 @ 02:56

          Let us know if run into problems while having the D2X in the 2nd x16 slot.
          Well, probably only other option is a Creative Sound BlasterX AE-5 or better, but as you can see here, that also might not work.
          I would not be hopeful for a solution. It might not be possible for me or anyone else in community come up with a fix. On the other hand, ASUS does not care solving these issues. Unless there is significant community uproar towards ASUS, they won't do anything.


          • Sascha08 Oct 2019 @ 06:44

            It works so far. The only weird problem at the moment is that when I tell Windows to "Reboot", it turns the PC completely off and then on again, instead of a normal reboot. But I don't know if that's soundcard-related.

            Admin update: Discussion regarding using Possible Solution 3 by the same author is taking place here.


  7. Jürgen08 Oct 2019 @ 12:22

    Ryzen 3700X
    Gigabyte X570 Aorus Xtreme Bios AGESA ABBA
    Asus Xonar STXII

    Issue: Crash/Reboot when changing rear to frontpanel. Also reboot when starting Discord.


    • CarvedInside09 Oct 2019 @ 03:50

      Thank you for the report.
      Have you tried any of the possible solutions listed above?


      • Jürgen13 Oct 2019 @ 00:50

        I will try this weekend and give you my feedback.


      • Jürgen17 Oct 2019 @ 00:20

        Tried Unixonar 1823 v1.80.. But it won´t let me start the Control Panel.


        • CarvedInside17 Oct 2019 @ 05:32

          For v1.80a and STX II cards you need to download this patched version of Asus Audio Center and copy paste it over "C:\Program Files\UNi Xonar Audio\Customapp\".


          • Jürgen18 Oct 2019 @ 18:05

            I tried the UNi-Xonar-W10-1825-v1.81a-r2.
            With this one the Control Center worked properly but when i switched from 2 Speaker to Headphones i had an immeadiitly crash.
            After reboot it worked fine a couple of trys to change fp and rp but than crash again.


            • CarvedInside18 Oct 2019 @ 22:07

              When it comes to your problem, changing between different drivers won't do much, except maybe v1.71.1 drivers. You will have to try the possible solutions, particularly no. 4 and no. 3.


  8. VJA16 Oct 2019 @ 10:58

    Hello to all. I have the MSI X470 Gaming Plus. I recently became the owner of Xonar DX. After installing the drivers, the card confuses the channels. Any channel can play from any speaker. (I have 5.1 JBL-631). Tell me, is this a problem of incompatibility between the motherboard and the sound card or is there a problem in the card itself and is it faulty?


    • CarvedInside17 Oct 2019 @ 06:08

      In your case the problem might be from the Xonar DX. Check the instructions that I've written at FAQ Q&A 20. Let me know if that fixed the channel problem and if the card works fine or there are other issues.


  9. Alex17 Oct 2019 @ 14:39

    Essence STX II is not working on MSI X570-A PRO.

    Known good card (was being used prior to system upgrade). Running on latest BIOS, have attempted a clean windows install, and switching PCIe slots / speeds. Regardless of configuration, any attempt by windows to use the card (including installing the drivers) results in an immediate system crash.


    • CarvedInside18 Oct 2019 @ 22:35

      Thank you for information. Have you tried with the v1.71.1 drivers?


      • Alex21 Oct 2019 @ 03:09

        I have now. Whilst the 1.71.1 drivers haven't presented any crashes, I cannot get any sound from the card through the heaphone output (and lack the means to test the other outputs).


        • CarvedInside21 Oct 2019 @ 03:35

          Have you tried enabling the headphone output with C-Media Panel and XonarSwitch?


          • Alex22 Oct 2019 @ 01:50

            Yes? Unless there's something more to it than with the standard drivers i.e. simply selecting "headphones" under the output mode.


    • alek25 Nov 2019 @ 20:16

      It's work fine for me.
      MSI X570 A-PRO/ ryzen 5 3600x with STX II (UNi Xonar STXII 11.5 v1.80b r3) in windows 10 pro
      UEFI/BIOS: 7C37vH5

      My card not working if I install it on the second slot (pci 1x) but in the very bottom and last slot, it’s work fine.
      (can’t try on another slot)


  10. FunStyle18 Oct 2019 @ 16:48

    Hello everyone, today I bought Asus STX II 7.1, put it in my "PCI_E5" slot with this configuration - AMD R5 2600, MSI B450 Tomahawk, flashed with the last BIOS, reset BIOS settings in advance. The card works stably with official drivers and the UNi Xonar W10 1825 v1.81a r2, the devices switch normally, there is no blue screen. I am glad.


    • CarvedInside18 Oct 2019 @ 22:20

      Thank you for sharing.


    • mat19 Jan 2020 @ 18:14

      hello funStyle i have the same configuration, but my asus essence stx2 (not 7.1) reboot the system when i install the driver ??
      Can you help me, i have upgrade the last bios, and my install of windows 10 is new.
      Thank you for advance.


      • CarvedInside20 Jan 2020 @ 21:17

        I already written in the page content what you could do, particularly in your case see possible solutions 3, 4, 7 and 2. Let us know if any of those worked for you.


    • Stefan Busch05 Feb 2020 @ 15:51

      Thanks, that encourages me to try the STX II again with my MSI B450 Gaming Pro Carbon AC. A year ago it hadn't worked (as I reported here: http://maxedtech.com/asus-xonar-unified-drivers/comment-page-208/#comment-178065), but that was before the advices about PCI-E slots and BIOS settings were given (and with older BIOS). Will report.


      • CarvedInside07 Feb 2020 @ 04:07

        Please let us know how that goes.


        • Stefan Busch14 Feb 2020 @ 04:35

          I probably should cleanly uninstall the drivers of my current 1st generation STX, before I try the STX II. What would be the best way to achieve this except doing a clean Windows installation?


          • CarvedInside15 Feb 2020 @ 01:54

            Uninstall the drivers, restart, install the desired driver version with "Run driver cleaning before install". It should be perfectly fine.
            There is the UNi Xonar driver cleaner, that you could use instead of the normal uninstaller, followed by a restart, but I don't think that's necessary.

            So until now you had the MSI B450 Gaming Pro Carbon AC with the an STX card and it worked perfectly fine?


            • Stefan Busch15 Feb 2020 @ 01:59

              I think the sound quality decreased over the years, regardless of the used mainboards. But I didn't have any reboot issues with the STX on the MSI B450 Gaming Pro Carbon AC.


              • Stefan Busch15 Feb 2020 @ 18:33

                STX II works in PCI_E_5 slot of MSI B450 Gaming Pro Carbon AC. No reboot issues or anything like this. (Doesn't bring back the sound quality though I once hat with the STX I on my Edifier speaker set. But this is then probably somehow due to age of these speakers.)


                • CarvedInside17 Feb 2020 @ 00:53

                  Thank you for the info. Did you had to change any of the PCI_E_5 settings in BIOS like I suggested in the possible solutions?

                  On the topic of sound quality. I am not so sure speakers degrade with use, with the exception of operating at very loud volume which can definitely degrade them. But if that were the case, you would have a much worse problem, as being exposed to loud sounds will permanently damage your hearing ability. Hopefully that is not the case.
                  If you haven't checked it yet, my Xonar best settings guide could be useful. There is another part that I haven't covered yet, concerning the correct and optimal setup of speakers, amp, cables and other hardware stuff. But ATM I am not to keen on writing that because most people don't want to view ads and neither make a donation to compensate me for my work.


                  • Stefan Busch20 Feb 2020 @ 01:56

                    As far as I can see, the BIOS doesn't even offter the option to change PCI E5 settings. It worked on first try, even with the original ASUS drivers. The settings option are quite limited in the most recent BIOS, but it promises "Improved PCI-E device compatibility", which seems to be true.
                    I will probably still return the STX II though, since it doesn't solve my sound quality problem


                    • Stefan Busch11 Mar 2020 @ 19:49

                      I just had one reboot while using the card, but can't say if it was related to the card

                    • CarvedInside14 Mar 2020 @ 03:46

                      The "Improved PCI-E device compatibility" was a fix for an previous BIOS version which cause system to not work at all when having a PCIe card installed other than the video card.

                  • Stefan Busch12 Mar 2020 @ 10:42

                    Did some experiments:
                    UNi-Xonar-STXII-11.5-v1.80b-r3.exe: Reboot during installation

                    UNi-Xonar-STX-II-11.5-v1.75b-r3.exe: no reboot issue, but apparently doesn't actually install a driver


                  • Stefan Busch21 Mar 2020 @ 19:47

                    I think I figured out by testing other speakers/environments that the sound problems were due to the old Edifier S530D set and may be partially my hearing. I'm about to do a clean Windows reinstall. After that, should I go with the offcially compatible STX (I) or with the STX II that apparently works now with the ASUS driver?


                    • CarvedInside23 Mar 2020 @ 14:58

                      Based on what you told me I believe you will still get the occasional BSOD with STX II, so I would recommend going with the STX.

      • CarvedInside14 Mar 2020 @ 03:53

        @Stefan Busch as continuation from this discussion.

        1. When you tried installing Uni Xonar v1.75b and v1.80b, did you previously uninstalled the original drivers you had installed?
        2. The installation was run with "Run driver cleaning before install"?
        3. Do you remember at what stage of the install process the system rebooted?
        4. "In the successful attempt reported on Feb 15th I had used the original Win 10 Asus drivers. These still work.". As in if you install them now, they install without a problem?

        Since you still get reboots, it means your system is not 100% stable with the STX II card. You could try the possible solutions, particularly 3, 4 and 7.


        • Stefan Busch14 Mar 2020 @ 05:21

          1. No
          2. Yes (I thought this replaces 1)
          3. No
          4. Yes
          I had a reboot once while using the Asus drivers a few weeks after I had installed them, so I guess it was not related to them or the card.


          • CarvedInside15 Mar 2020 @ 05:26

            For v1.80b r3 the "Run driver cleaning before install" is capable to also uninstall the installed drivers, but there might be certain conditions where you would be required to restart the system by the uninstaller, such a thing is not possible when the drivers are uninstalled from the "Run driver cleaning before install" routine.
            For v1.75b r3 that's not the case, it was made to be complementary to the manual uninstall.

            Maybe the restart issues during v1.80b r3 are because you did not uninstall the current driver. If you want to try, uninstall current drivers, restart, install the v1.80b first without "Run driver cleaning before install" and see if that works.

            Outside of those with these compatibility issues with Ryzen motherboards I don't remember anyone reporting getting BSOD's when installing v1.80b r3. Either with the current BIOS restarts happen for you only under certain conditions or the fact that you have not uninstalled the current original driver causes some problems.


  11. Stahlkocher30 Oct 2019 @ 21:58

    Biostar X570GT8: Xonar DGX works flawlessly with all Bios versions up to including AGESA With the AGESA Beta Bios the system does not post and the post code LED shows code 97: "Console Output devices connect". Tested with both a RTX 2080 and a GTX 960 as GPUs.

    My guess: The mainboard tries to use the soundcard as display output. No idea how to change that behavior yet, chipset or CPU lanes make no difference.


    • CarvedInside30 Oct 2019 @ 22:11

      Look in your BIOS for option called "Initial Display Output" or similar, this would allow you to select in which PCIe the main video card is plugged.
      You should contact Biostar and let them know of the situation.
      I am wondering if it's because of changes that AMD made to AGESA Beta or it's because of other changes Biostar made to their BIOS. Guess we will see if others report similar issues with other motherboard.
      Keep us updated.


      • Stahlkocher30 Oct 2019 @ 22:57

        I was not able to find an option to set the video output. What I found are options for legacy/UEFI modes. Soundcards seem to start in UEFI mode by default, GPUs in legacy. My GPU does not support legacy, but well. Biostar's BIOS is a mystery at times.

        I will have some time tomorrow to experiment a bit more.


        • CarvedInside31 Oct 2019 @ 01:03

          Look for Chipset->Northbridge->GFX configuration->Primary Video Device. In the manual it shows it has only options: NB PCIe slot Video (Default) / IGD Video. If even with this new BIOS it still only those 2 options are available, might be worth a shot setting it to "IGD Video" if it was set to "NB PCIe slot Video (Default)" or viseversa, and try it with Integrated Graphics being set to "Auto" and another time with it being set to "Disabled".


          • Stahlkocher31 Oct 2019 @ 23:56

            The manual is sadly not even remotely comparable to the real BIOS. The current Beta Bios at least only got the Gnb Hd Audio option and the PSPP Policy options available, the other four options of the GFX Configs menu are removed.

            I just checked the 1004B Beta against the 1003ABBA Bios which I still got installed on the second BIOS chip and the Abba Bios also lacked these options already.

            I wrote to the Biostar support and will see if they fix the BIOS. If they don’t I will either have to see about modding the BIOS myself or, if I decide that I do not want the hassle with always modding the BIOS again when a new one comes out, returning the board as defective.


            • lolek03 Nov 2019 @ 18:47

              The same problem on the Gigabyte x570 motherboard (Bios with AGESA


              • CarvedInside03 Nov 2019 @ 20:01

                Have you tried setting "Initial Display Output" to the PCIe slot in which the main video card is plugged?
                Tell us the full name of the motherboard and which Xonar card you have. Did it worked fine before?


                • Ezgera13 Nov 2019 @ 00:51

                  While Gigabyte managed to fix the 1004 BIOS for some boards to restore compatability with add-in cards like soundcards, Biostar did not manage to do so with the final 1004 release BIOS.

                  Still no boot with the Xonar DGX.


  12. lolek03 Nov 2019 @ 21:32

    Gigabyte x570 Aorus Pro, Asus Xonar DX
    Bios F10a (AGESA - not working. Works in all previous bios versions.
    Initial Display Output: "PCIe 1" (Only long pcie slots are visible). Xonar card connected in the last short (x1) PCIE port.

    More reports of this problem:
    "BIOS F10a:
    Bxxxx - Asus Xonar Essence STX in pci-e x1, GTX 1080 ti. X570 Pro. CPU not mentioned. Not working.
    Lxxxx - Asus Xonar DX in pci-e x1. GTX 1070 X570 Pro Wifi. 3700X. Not working.
    Dxxx - nothing in pci-e x1. GTX 1070. Board and CPU not mentioned. Not working.
    Saxxxx - Something in pci-e x1. Vega 56. Board and CPU not mentioned. Not working.
    kuxxx - Asus Essence STX in pci-e x1. GTX 1080ti. X570 Elite. CPU N/A. Not working.
    haxxxx - Creative SB AE-7 in pci-e x1, EVGA 2080TI. X570 Master. Ryzen 3900x F10a. Not working
    1xxxx - avermedia live gamer hd 2 в pci-e x1, lower pci-e asus xonar d2, Msi GTX 1080 ti. x570 Master. 3700x. Not working.
    Bexxx - PCIE 1x: Creative Sound Blaster X-Fi Titanium Fatality Pro, PCIE 16x: GV-N166TOC-6GD, PCIE 8x: GT1030-SL-2G-BRK, X570 Elite, 3700X. Not working"

    Source: https://extreme.pcgameshardware.de/prozessoren/470191-sammelthread-amd-ryzen-2282.html#post10081333


    • CarvedInside03 Nov 2019 @ 23:24

      Thank you for the information.


      • Leszy04 Nov 2019 @ 13:33

        Same issue for Gigabyte x570 Master BIOS F10a and Asus Xonar DX.
        Works well with F7a, stuck on boot on 10a. Switching to other PCI-e slots doesn't helps. Removing the sound card solve the issue.


  13. U105 Nov 2019 @ 09:09

    Asus X370 Prime Pro, AGESA, Ryzen 3600
    Xonar DG -> ASMedia 1083 PCI bridge -> Lowest PCI-E x1 slot on the board

    No problems. Bridge shows up as PCI\VEN_1B21&DEV_1080.


  14. Gerd05 Nov 2019 @ 22:48

    I have an Aorus b450 m and the universal drivers worked out of the box!
    Cheers Gerd!


  15. x570-f05 Nov 2019 @ 23:33

    Asus ROG Strix x570-F gaming
    Ryzen 7 3800x
    Asus Xonar essence STX II

    Does not work, crashes and reboot-loops the system when any settings are changed.



Leave a new commentReply to comment

Comment received.
Your comment may be held for moderation. If it does not show up immediately, please be patient. Comments have to comply with these rules:
  • English language only
  • Don't post insults or threats
  • Try to keep the discussion constructive and informative
  • Don't post questions without doing a search beforehand
  • For replies to individuals regarding the SAME discussion, use Reply to write to that individual. For a NEW issue write a new comment.
  • Make your comment easly readable. Write the product names how they are originally written or at least capitalize their first letter. Write "i" as "I". Add a space after end of a sentence and beginning of another (e.g. ".I" -> ". I").

We've noticed that you're using an AdBlocker

It's not just you, over 66% of our site's visitors are blocking the ads.

Please disable adblock for this website and refresh this page if you:
find the content useful
want us to create more useful content and software
want tech support through the comment section

The ads are placed so that there is minimal interference with page reading. There are no pop-up, pop-under or sticky ads.

Alternatively, you can support us by making a donation.