1. Andreas19 Nov 2019 @ 23:11

    I contacted Asrock because of the problem with my Asrock x570 Taichi in combination with a Asus Xonar DGX. They supplied me with a new BIOS 2.56 which fixed the issue.


  2. dante25720 Nov 2019 @ 12:21

    Asus X570 TUF GAMING X570-PLUS (WI-FI), Asus Xonar DGX
    PC stuck on POST screen after BIOS Update 1404 AGESA and in reboot loop. Entering BIOS is not possible.
    Removing Xonar card resolves the problem.


    • raycamui23 Nov 2019 @ 11:57

      I had the same problem and got a modified BIOS from from the support of an ASUS distributor.
      It has been confirmed that Xonar DSX works without problems with this βBIOS.
      The official BIOS will be released soon.


    • Bronko23 Nov 2019 @ 15:11

      same here but with the non wifi version mobo, hope there will be a fix soon. The mic quality of the onboard audio is really bad.


    • Bronko28 Nov 2019 @ 16:47

      with the latest update my xonar dgx does work again


  3. Sallem25 Nov 2019 @ 03:04

    My old Xonar DX works just fine in a Ryzen 2600 mounted on Gigabyte B450 M Motherboard. No BSODs or Freezes.


  4. ravdo25 Nov 2019 @ 14:37

    There's a new Beta BIOS for some x570 ASRock Boards today, with the description : Improve PCIe card compatibility.

    My guess, this would fix the Xonar Sound cards issue.


  5. John25 Nov 2019 @ 22:03

    AGESA also causes issues with Creative cards.


  6. DarkDan26 Nov 2019 @ 19:05

    Xonar Essence STX x ASUS Prime X570-P with BIOS 1405 works great. But didnt boot with 1403, 1404.


  7. Sandro26 Nov 2019 @ 21:43

    Got an BIOS from ASUS support for Asus Pro WS X570-ACE.
    Bios version 1201 beta.

    After installing the update i was able to use my Xonar Essence STX II again.
    Important before upgrading - it is a beta version, so there may be instabilities.


    Dont forget to clear cmos (jumper or short-circuit battery)


    • afg28 Nov 2019 @ 02:50

      Thank you so much for this. After installing the beta BIOS last night and troubleshooting for a few hours, it finally detected my Xonar DX and I got all the drivers installed!

      It's really weird. First it detected it, then suddenly after I installed the ASUS sound drivers, it went dark and could not detect itself. Restarting multiple times, clearing CMOS, and switching it between PCIe x16 port 2 and 3 made it detectable again so I could install CarvedInside's C-Media drivers.

      The HT Omega eClaro however is not being detected and I am really not in the mood to troubleshoot for another 4 hours to make it work. Definitely a beta BIOS, but it works nonetheless.


    • CarvedInside07 Dec 2019 @ 06:19

      Thanks for sharing.
      Regarding other issues (reboot when changing card settings, when installing the driver), did you do any of the possible solutions listed above (like switching PCIe to GEN3/2/1) to make it work or it just worked fine without doing anything? In which PCIe slot is the soundcard plugged-in?


  8. casimirovsky26 Nov 2019 @ 22:30

    Motherboard Asus Prime X570-P with Xonar DX soundcard. Updated to Bios 1405 and no more problems with PC not booting. Everything working as expected. Finally!


  9. rkupka27 Nov 2019 @ 11:19

    ASUS Prime X570-E with Creative Soundblaster-Z - bios 1202 or 1404, soundcard does not work properly, sound is distorted and cracks, otherwise it is stable and does not cause boot problems. I'm using onboard sound for the moment.


  10. DonkeyKong27 Nov 2019 @ 14:08

    I can confirm the latest Asus X570 TUF GAMING X570-PLUS (WI-FI) 1405 Bios has fixed the issue with Xonar Essence STX II - Thank you Asus! I have just install the card for the first time today 🙂


    • CarvedInside27 Nov 2019 @ 20:58

      You are talking about the no boot issue right?
      In regards to the other issues (reboot when changing card settings, when installing the driver), did you do any of the possible solutions listed above (like switching PCIe to GEN3/2/1) to make it work or it just worked fine without doing anything? In which PCIe slot is the soundcard plugged-in?


      • behzadm08 Dec 2019 @ 18:25

        Today I installed Essence STXII in PCIEX1_2 on my ASUS TUF X570-Plus (Wi-Fi) with BIOS 1405. Motherboard boots without problem. I installed ASUS Win10 drivers and the 2nd time I tried to switch from FP to headphones, I had a black screen followed by reboot. I tried lowering PCI-E Gen from within BIOS from 4 to 3 and from there down to Gen 2. I have not seen any black screens so far on Gen 2. I'll keep you posted in the coming days if I run into any issues.

        P.S. My GPU is 2.5 slots thick, so I am not comfortable installing STXII into PCIEX16_2 to partially block GPU fans/heat sinks.


        • CarvedInside09 Dec 2019 @ 00:56

          Thank you for the info. When you switched to Gen 3 you still had the problem? Can you tell me the exact name of the PCIe Gen option that you've changed and where is it placed?
          Not that it's necessary atm, but maybe you can switch the video card to the PCIEX16_2 and plug in the STX II in it's place.

          Keep us updated.


          • behzadm09 Dec 2019 @ 18:11

            You're welcome. I used the PCIE gen settings under Advanced Tab => Onboard Devices Configuration. I am afraid I had to go down to Gen 1 in succession to no avail. The card remained stable on Gen 2 for the longest duration but it eventually either caused a reboot upon switching inputs or simply when I changed a window's position while playing music. Then again, this was all on PCIex1_2 which is the furthest slot from the CPU.

            Observation: I noticed my M.2 SSD ran a few degrees hotter in idle (41 vs 44C), even though the sound card was not physically blocking its heat sink.

            I might try PCIe16_2 as well. I'll let you know how it goes when I do.


            • CarvedInside10 Dec 2019 @ 00:50

              If you can, take a screenshot or a picture of the Onboard Devices Configuration BIOS page and send it to me via e-mail or upload it somewhere(imgur,imgbb, etc.).

              Looking at your board's manual, the PCIeX16_2 is not connected directly to the CPU but instead it's connected to the chipset just like PCIeX1_2, so there isn't much difference but you should try any way.

              Regarding the M.2 SSD, you should connect it to the first M2 slot as that one is directly connected to the CPU so you have lower latency and possibly better speeds.


              • behzadm13 Dec 2019 @ 17:56

                Okay, here goes the screenshot from BIOS showing where the selector is for PCIe gen1-4.


                Please note that internal audio is enables since I have removed STXII and am listening to audio through an external DAC via toslink.

                I noticed too that PCIe16_1 is the only slot connected to the CPU. So, I have already lost hope that STXII will truly become stable on ASUS TUF X570-Plus unless ASUS role up their sleeves to come up with a BIOS update just to resolve this issue.


  11. Dominix30 Nov 2019 @ 16:59

    Update on Asus Prime x570 Pro, latest bios from asus site v1405 fixed an issue with Xonar DX, now it works fine, no problem with boot while card is in last slot on mobo.


  12. Czartafarianin04 Dec 2019 @ 16:52

    I just upgraded my mobo to Asrock X470 Taichi and I have issues with booting when Xonar Essence STX II is installed. After output switch click screen stays black and PC restarts after 30-60 seconds, and it does it again, and again and again ;). Can't even get to windows login window.


    • CarvedInside04 Dec 2019 @ 23:41

      Which BIOS version does you motherboard have? Maybe it has the one with the buggy implementation of AGESA
      Have you tried other PCIe slots?


      • Czartafarianin05 Dec 2019 @ 00:46

        Bios 3.60 with AGESA Combo-AM4 ABB. But I managed to get it working though by moving to last PCIe x16 slot. Works like a charm now, however when using this PCIe slot the second m2 is disabled according to manual.


        • CarvedInside07 Dec 2019 @ 07:14

          In which slot it was before? Which CPU do you have?


          • Czartafarianin07 Dec 2019 @ 11:58

            Before it was in PCIe x1 (PCIE4) slot. I have 3700x. Now I have it in last PCIe x16 slot (PCIE5).


            • CarvedInside08 Dec 2019 @ 22:56

              Thank you for the info. Really interesting as both PCIe x1(PCIE4) and PCIe x16(PCIE5) are connected to the chipset.


              • Czartafarianin12 Dec 2019 @ 23:47

                Today I got my first reboot with this card when switching output. I switched from Headphones to Speakers and PC rebooted instantly. Since that time I tried some switching and managed to reproduce 3 reboots. Twice when changing output, and once rebooted when starting discord. So far it happens to reboot at random output switching, the only common thing was that discord was running minimized. Strange because so far it was working fine.
                Also just an information that if you have this reboot problems try to avoid opening steam when switching outputs ;). My steam was opening when reboot happened and reset all my settings. If steam is fully opened and reboot happens then it should be fine ;).


                • CarvedInside13 Dec 2019 @ 03:34

                  Thanks for the info. Especially for Discord and Steam crashes you could try the new possible solution 7. I am not sure if it will offer any benefit for the crashes when switching from Headphones to Speakers in general. If things don't work fine, you also can try possible solutions 3 and 4. Let me know how things go.


                  • Czartafarianin12 Jan 2020 @ 16:08

                    I wrote to Asrock support and got the newest BIOS from:
                    After installing it I moved my soundcard to PCIE4 (PCIe x1) and booted fine. No reboot loop issues so far.
                    As for randomly reboots when switching output or opening discord, so far so good also. However previously 1 week passed before I got the first reboot so I will use this setup for now and see if any issues appear.


                    • Czartafarianin15 Jan 2020 @ 21:08

                      I was happy too early. Today when I switched to headphones my PC rebooted. I will try to clean install windows when I will have time and see how things go from there.

    • CarvedInside16 Jan 2020 @ 21:40

      As a continuation from this discussions since it reached the maximum number of replies. Reply to this comment if you have any other updates.
      Sorry to hear that did not work. What about possible solutions 3 and 4, have you tried those?


      • Czartafarianin19 Jan 2020 @ 21:46

        I just noticed this reply, please delete the previous one.
        Reinstalling windows sadly didn't fixed reboot issue and even introduced more problems. I got 2 resets, once after switching output and once while opening discord. Also I don't know why but microphone boost option disappeared and my mic had low volume because of that. I tried installing 2 different unixonar drivers and asus official ones but I couldn't restore this mic boost option.
        I haven't tried solution 3, I tried solution 4 (moved back to PCIe5, but still got one reset when switching output). I gave up and uninstalled this card from my PC. I will get AIM SC808 from my friend and if this card doesn't work, then I will just buy external soundcard or DAC. I hope other x470 taichi owners have more luck :).
        Also thanks for your support and great work with unixonar drivers.


        • CarvedInside20 Jan 2020 @ 21:10

          You are welcome.
          Thank you for the info. About trying solution no. 4, did you try the PCIe3 (the secondary x16 slot)?
          When you try the AIM SC808 please let me know how that goes.
          I don't know why Microphone Boost would be missing. If you decide to go back to the STX II and find a way for the system to be stable, we'll see what can be done about that.


          • Czartafarianin20 Feb 2020 @ 17:39

            I have AIM SC808 for 3 weeks now and it works. No reset issues at all, I can switch outputs freely :). I have no issues with windows not detecting card either. If any problems appear later I will let you know.
            Quite happy with the card so far, sound quality is similar to STX II. Microphone input is much worse though, I am getting plenty of noise, so I unplugged the extension and I use motherboard mic input. I also miss xonar switch because everytime I switch outputs I need to also adjust volume level. Do you know if there is something similar for SC808?


            • CarvedInside21 Feb 2020 @ 20:40

              Thank you for the info. Since the issues with the STX II, have you tried the card again in you old PC or a non Ryzen PC? Let me know if you try that.

              I don't know of such tool for your AIM SC808. FYI your card has the CMI8888 audio chip, which is also used in Asus ROG Xonar Phoebus and PowerColor Devil HDX soundcards, so if someone made a tool for either of those, it should work for your card as well.


              • Czartafarianin17 Mar 2020 @ 11:40

                I was using STX II in my old setup (MSI mpower z87 with i7 4770k) and it worked without issues for about 4-5 years.

                SC808 so far works very well and no problems so far.


  13. Pro05 Dec 2019 @ 08:14

    Asus Prime x570 Pro and Asus Xonar DSDX, everything works on 1201 BIOS.
    1) Can you rollback after updating to 1405?
    2) Did anyone see any improvement from 1201 to 1405?


    • CarvedInside07 Dec 2019 @ 06:53

      1. According to these reports you might not be able to roll back on ASUS X570 motherboards.
      2. I don't see anything important with to be worth updating except maybe faster boot. If your system works fine there is no need to update.

      Your card is actually the Xonar DSX right?


      • Pro19 Feb 2020 @ 07:36

        Sorry, made a typo. I have the Xonar DX card.
        and yes, the system is rock solid and fast.
        I did not update the BIOS, still on 1201.


  14. Sascha05 Dec 2019 @ 13:55

    Can somebody double down on the D2X is working with the "ASUS ROG STRIX X570-E GAMING" Bios 1405?


      • Sascha08 Dec 2019 @ 17:05

        Thanks, I did the Update to 1405 and it worked just fine. 🙂
        I did not have the option to choose the GEN-Type before...would it now be possible to use the d2x in a PCIe 1x Slot set to GEN3 or is the second 16x still required (as mentioned here)?

        Thanks again. :o)


        • CarvedInside08 Dec 2019 @ 23:36

          Just so you know, I added a reference to your previous comment.

          With BIOS 1405, they added another option to switch PCIe GEN-Type? What is it called and where is it placed? I think you would need to test it. Let us know of the results if you do.


          • Sascha09 Dec 2019 @ 03:06

            Hey, no Problem and thanks.
            I don’t know if the update brought “another” option, tbh. I came from 1201 and even though I read several times that I should change the pcie gen mode, there was just no option. I looked in every part of the bios to find it but it just wasn’t there. Now with 1405 it just was. Every single slot has the option now, just like that. I don’t know if I was blind before or if there was something wrong…but now it’s just there. Not even hidden in any way. And I wasn’t in ez mode before. So…I’m just happy that I have the option now. 😀
            I will upload a screenshot tomorrow and maybe check if the 1x slots are working now.



Leave a new commentReply to comment

Comment received.
Your comment may be held for moderation. If it does not show up immediately, please be patient. Comments have to comply with these rules:
  • English language only
  • Don't post insults or threats
  • Try to keep the discussion constructive and informative
  • Don't post questions without doing a search beforehand
  • For replies to individuals regarding the SAME discussion, use Reply to write to that individual. For a NEW issue write a new comment.
  • Make your comment easly readable. Write the product names how they are originally written or at least capitalize their first letter. Write "i" as "I". Add a space after end of a sentence and beginning of another (e.g. ".I" -> ". I").

We've noticed that you're using an AdBlocker

It's not just you, over 66% of our site's visitors are blocking the ads.

Please disable adblock for this website and refresh this page if you:
find the content useful
want us to create more useful content and software
want tech support through the comment section

The ads are placed so that there is minimal interference with page reading. There are no pop-up, pop-under or sticky ads.

Alternatively, you can support us by making a donation.