1. Kuratz09 Dec 2019 @ 01:34

    MSI MEG X570 ACE

    Asus Xonar essence STX II working flawless on lowest PCI-E x1 slot


    • Ryzen11 Jan 2020 @ 14:21

      Have you problems in other slots to? Mine is in the lowest 16x slots and then it comes to reboots maybe all two days or so.


      • CarvedInside11 Jan 2020 @ 18:56

        You also have the MSI MEG X570 ACE motherboard with the ASUS Xonar STX II card? Have you tried any of the possible solutions (especially 3 and 4)?


        • Ryzen07 Apr 2020 @ 19:18

          Sry I am a "bit" late. Yes, I have also the x570 ace and tested all slots. It's not working. Or better the soundcard works, but my system restarts at some points.


          • CarvedInside07 Apr 2020 @ 21:12

            No problem, thanks for getting back. Have you also tried switching the PCIe version to Gen1 for the slot where the STX II card is plugged? What CPU do you have?


            • Ryzen09 Apr 2020 @ 19:06

              i almost trying all to get it work properly. i installed it yesterday back in and test it out again. yesterday it works like nothing, but today i tried to start my pc and then it died right away. i installed the newest chipset driver yesterday to. so no change so far. i let you know if i can get it to run stable.


              • Ryzen11 Aug 2020 @ 21:12

                ok it seems to work for now. i have installed a bios update to 1.9 and set the pcie_3 gen to 1. when i set it to 2 or 3 i am not even com to windows, same in a other slot. as far i can see it not afect the first or second m.2 slot.

                CPU is btw 3900X


                • CarvedInside12 Aug 2020 @ 02:16

                  Good to know. Please clarify the "same in a other slot" part, does the card also work fine in other PCIe slot but only if you set it to Gen 1? Which PCIe slot?


                  • Ryzen12 Aug 2020 @ 20:23

                    no i can only change slot 1 and 3 to other gen. so pcie slot 1 is my gpu. pcie slot 3 is the only free one i can change gen to. if i change slot 1 and 3 to gen 1,2,3 its not working in other slots. so no matter wich slot i try its not working just pcie slot 3 and maybe 1 to. but my gpu is watercooled so i can't easy test it there.


    • ScarabParamit17 Apr 2020 @ 08:53

      MSI MEG x570 ACE BIOS 1.80 - WORKS if placed in PCI-E that has bios options to limit bandwith from Gen4 to for example Gen1/2/3. Those are PCI-E_1 and PCI-E_3 on my board (somewhat sad i can't change PCI-E_4 or PCI-E_5, STXII will reboot pc if used in in both PCI-E_5 and small PCI-E_4.
      What Gen to use depends on configuration i think, I set mine to Gen2 and don't think it has any impact on M.2 slots using those lanes... on Gen2 i can still run NVME Samsung 970EVO PLUS (3,300mb read/s 2,800 write/s) with same speed as on Gen4. I only don't like this placement because my graphic card is 2,5 slot and clearance for air flow is now limited. Either way it works, i prefer soundcard than overpriced DAC, pity they used those bad controllers.
      Anyone has idea about using RAISERS? Was wondering does those can help/limit bandwith and such or maybe additional capacitors or some other electronic components could fix rebooting...for sure at some point i will use one just to move card away from graphics and maybe just place it and 7.1 sister card on FRONT PANEL, just don't have time right now so don't wait on report. STAY HEALTHY.


      • CarvedInside18 Apr 2020 @ 22:46

        Thank you for the providing the details. You could also switch places between the GPU and the sound card if that would leave more clearance for the GPU.

        Regarding manually setting the PCIe version for the other slots, you should contact MSI support, inform them of the problem and ask them to implement those options.

        No idea about raisers, for the soundcard you would have the same bandwidth with one, as the soundcard is PCIe x1. I'm thinking there is the possibility that using a PCIe raiser would exacerbate the problem since the problem seams to be related to PCIe signals. We would know how that goes only by testing that.


  2. ravdo09 Dec 2019 @ 21:37

    ASRock X570 Steel Legend - AGESA B with the latest BIOS (P2.20)
    ASUS Xonar DX is working properly again


  3. JoeyD11 Dec 2019 @ 00:34

    Xonar Essence STX on MSI Tomahawk B450 Max board using 7C02v35 bios (most recent as of December 2019).

    Installed most recent Uni Xonar driver, clean install and with low latency DPC install option

    After remembering it needed Molex power cable(!) I heard the familiar click on boot and was able to hear through all the output options, including front panel. Set to 44.1k 24bit.

    Haven't played Steam games again. Still setting stuff up and organising the hard drives. Will need to test with Shadow of the Tomb Raider. That caused me some problems in the previous setup (FX 6300) so that'll be the biggest test. Just need to find time to do it. Hopefully this weekend.

    PS Disabled onboard sound chip
    PPS I put the card in the lowest PCI-E slot. That may help. 1-4 seem to be somewhat linked, so using the 5th one may improve compatibility


  4. Sascha11 Dec 2019 @ 13:18

    My Xonar D2X is working now in the PCIe 1x Slot!
    Set PCIe 1x Slot to GEN1. System boots, card is working fine so far.

    ASUS ROG STRIX x570-E Gaming, UEFI 1405 with the new PCIe Gen options (https://i.ibb.co/XScBf1F/ROGSTRIXx570-GAMING-E.jpg)


    • Sascha12 Dec 2019 @ 04:13

      Okay, something just happened:
      I set the Speaker to Stereo from 5.1 because I wanted to use Voice Communications with a Headset and when I switched back to 5.1 the card clicked and the system rebooted. Booted straight up and worked again, but yeah...that happened. So I guess they have a little more optimizing to do. 🙂


      • CarvedInside13 Dec 2019 @ 04:42

        You never had this problem when you had the Xonar D2X card plugged in the 2nd PCIe-x16 slot?
        You may also try the new possible solution "7. Disable Xonar's recording devices" and see if it has any impact in your case. As oppose to other cards like DGX, DSX, DX and STX, the D2X has the ALT recording input which I am thinking might be a cause for these restarts.


        • Sascha29 Dec 2019 @ 11:49

          Tried everything I can imagine now for the last days. I have always disabled all devices I don't use. Since I'm using a USB-Mic, all recording devices from the card are always disabled, so are all playback devices except for "D2X Audio Device". But still this thing happens occasionally, approx. every 2 days. I hear the clicking and the whole system reboots. The card is now back in the second PCIe 16x slot and as expected there are no problems anymore.
          I guess/hope it's somehow possible to get stable through UEFI Updates, since this is still "progress" that it "works" in a 1x slot at all.


          • CarvedInside30 Dec 2019 @ 01:15

            Thanks for the update. Let us know if there are any other developments.
            I am hesitant to believe ASUS or AMD are working to fix this, the fact that it worked better than before in a 1x slot could be the indirect result of some changes they made.


            • Sascha30 Dec 2019 @ 10:48

              I hope they do, but as I understand it other sound cards have problems, too. So AMD kind of has to do something, right? 🙁

              Maybe ASUS will release a new slate of sound cards which are compatible. That would be the worst option but at least it would be an option. I'm looking for alternative sound cards sometimes, but there isn't really much to find these days besides ASUS and Creative. Creative users have reported problems, too. I want to stay with ASUS.

              Let's hope it is just a matter of maturing the x570/PCIe 4 platform and someday it will work as intended.
              If I could choose I would love to use the D2X forever, or at least as long as my analogue 5.1 System is alive. I guess my next will be digital but for now (and the foreseeable future) I need the analogue 5.1 ports and I love the output of the D2X in that regard.


  5. kean3D13 Dec 2019 @ 03:34

    second official bios (v2008) with patch agesa for Asus plus b450-prime
    i jumped the first one (v2006) with new agesa cause was afraid with problems as knowed on most x570/x470 mobos with pci-ex pheriphrials;
    so, can confirm here everything ok, no problems at all with this bios,
    Xonar STX II works like a charm as before, Win10 Pro 1909 (18363.535)


    • kean3D13 Dec 2019 @ 04:26

      the most difference here between older bioses and new one is that on this mobo there is not “spread spectrum” setting in bioses, so the bus block was always like 99.8mhz, now with new agesa bios bus clock is fixed to 100mhz
      so very few mhz more in ram clock and cpu clock cause of that (no pbo, oc manual for cpu and ram); bit faster booting, stop.


    • CarvedInside13 Dec 2019 @ 06:39

      It's good to know.


  6. LCA04 Jan 2020 @ 00:13

    STX Essence with 1.81 driver
    STX in second to bottom PCIe slot (PCIe x8)
    Windows 10 version 2004 (OS Build 19041.1)
    Gigabyte x470 Aorus Ultra Gaming 1.0 with F50 bios
    No issues at all to report with either the actual PC nor the STX. I also tried the F41 bios and had no issues with that and the STX either.


  7. Salty07 Jan 2020 @ 20:56

    Using an Asus D2X Xonar in the bottom most PCIex1 slot on an MSI X570 Gaming Edge Wifi works fine with the UNi-Xonar-STXII-11.5-v1.80b-r3 drivers works perfectly. Couldn't use the UNi-Xonar-W10-1825-v1.81a-r2 drivers as they caused a system restart on installation.


    • CarvedInside08 Jan 2020 @ 12:14

      Thank you for the information. Did it worked without changing the PCIe slot speed in the BIOS? Which BIOS version your motherboard have?
      Let us know if the situation changes.


  8. Dimitris P09 Jan 2020 @ 21:24

    Asus Prime X570-P, Asus Xonar D2X, latest bios (1405), working without issues so far.


    • CarvedInside10 Jan 2020 @ 10:26

      Thank you for the information. Did it worked without changing the PCIe slot speed in the BIOS?


      • Dimitris P10 Jan 2020 @ 16:15

        Yeah I didn't switch PCIe speed, left it on auto. Forgot to mention, this is with UNi Xonar W10 1825 v1.81a r2 drivers, default installation.


  9. Christophe12 Jan 2020 @ 00:01


    I have just build a new computer and I'm facing a lot of problem trying to install drivers for my Xonar DSX. My motherboard is a TUF Gaming X570-Plus. Firstly, the computer wasn't booting at all, but an update to the latest BIOS version FIX that.
    Now, the problem I have is that I am unable to install official DSX drivers or UNI Xonar Drivers (any version). Everytime I arrive at the step of installing the driver, the soundcard is doing the usual "Click" sound then just after computer reboot. I've try to change the PCI-Ex mode to Gen 1 but no difference. I have try to install them in safe mode or in unsigned drivers mode but It always end to a fail. (code52)
    Any solution please?


    • Sascha12 Jan 2020 @ 05:14

      Did you already try putting the card in the second PCIe 16x Slot (the long slot, not one of the short ones)? Most of the time that seems to work for x570 boards.


      • Christophe12 Jan 2020 @ 15:25

        This is the only one I didn't try, I'll try and let you know. thx


        • Christophe12 Jan 2020 @ 16:22

          Drivers successfully installed, but after that, it's not stable. Audio control from Xonar software give error and trying to make adjustment from Windows settings can make the computer crash.


          • Sascha13 Jan 2020 @ 05:49

            You could try an older driver version and I think someone mentioned lowered RAM speeds. Just read all the messages posted here and try some stuff. 😀
            Maybe you have to wait for another BIOS update or someone with your card & motherboard has a solution.
            For me the slot change "fixed" it competely.

            Good luck!


  10. Phil12 Jan 2020 @ 20:54

    I am having the same issue with my Asus Essence STX II running on Asus x590-F w/ Ryzen 3900x cpu. Every time I hear the normal click is when my computer crashes. Seems to be associated with Discord loading but seems to also happen at windows boot up just prior to the login screen. Would love some input from someone who was able to resolve this issue.


    • CarvedInside13 Jan 2020 @ 16:05

      The motherboard name you typed is wrong and incomplete. Is you motherboard the Asus ROG Strix X570-F Gaming?
      I already written in the page content what you could do, particularly in your case see possible solutions 1, 3, 4 and 7. Let us know if any of those worked for you.


    • Tiny_Montana18 May 2020 @ 02:52

      I have a 3900X on an MSI X570 MEG Ace, and and Essence STX II. Discord also crashes my PC right at the soundcard click just like yours. I am on latest Asus drivers. I have followed a suggestion on this forum to try and specify a pci-e gen other than 4. Sadly, I can only do so for slots 1 and 3, but I also have an option to specify chipset gen, which I set to 3. So I will see what, if any results this gives and report back. To the mods and owner of this site, thank you for maintaining this site.


  11. Stanley13 Jan 2020 @ 12:22

    X470 Gigabyte ultra gaming and STX II here, I tried all the solutions mentioned but the PC reboots always


    • CarvedInside16 Jan 2020 @ 21:30

      Which CPU do you have? Does your motherboard allow to change the PCIe slot speed?
      You should contact Gigabyte support and let them know of the issue, maybe also provide them with a link to this page for more info.


      • Stanley16 Jan 2020 @ 22:05

        Ryzen 3400g 2400g and the motherboard allow to change the PCIe slot speed. Yesterday I changed the linear power supply of the STX II with another one and now the sound card works perfectly, no reboot and no problem so far.


        • CarvedInside16 Jan 2020 @ 22:42

          You have to fill me on what do mean by "changed the linear power supply of the STX II". Did you changed the 12V STX II power input from the PC power supply with that from a (separate) linear power supply? Did you swap some power components on the sound card?

          Right now in which PCIe slot the card is placed? At which PCIe speed is it set?
          Let us know if you start experiencing issues.


          • Stanley17 Jan 2020 @ 00:17

            The sound card is on the last PCIe slot, the PCIe speed is set to AUTO. Previously I used two power supply, one for all the PC and one just for the sound card, now I use just one linear power supply Teradak 600W for all the PC included the Asus sound card, and so far the STX II works perfectly fine. I suppose that my previous power supply was defected


          • Stanley01 Feb 2020 @ 15:41

            No problem so far, the sound card works perfectly fine

            P.s. my CPU is not the Ryzen 3400g, is the 2400g


  12. Stanley13 Jan 2020 @ 15:26

    Seems to be a new driver for the stx II released from Asus on 2019/12/25


    • CarvedInside13 Jan 2020 @ 15:44

      Thanks for the head up. They just removed the "Beta Version" tag from the name. I've checked the driver files and there is nothing new, it's all exactly like the previous driver released in 2015.


  13. benvader081516 Jan 2020 @ 18:25

    My STX II 7.1 works perfect with my Asus Prime B450-Plus (Bios V2008) Plus with R5 3600, Window 10 Pro Build 1903 and your Driver 1.80b R3. I tried different PCI-Slots (PCIEX1_3, PCIE1_2 and 16_2) - no problems nor BSOD.


  14. OneFour3720 Jan 2020 @ 01:42

    Ryzen 7 1700
    MSI X370 Krait Gaming
    ASUS XONAR STX with 1825 v1.81a r2 drivers
    10.0.18363.592 (Win10 19H2 [1909] November 2019 Update)
    Perfectly working since 2017-05-21, never had real chance to appreciate Your work. Keep it up my man ♥
    ~ https://i.imgur.com/k6Qt8ac.jpg


  15. Uli25 Jan 2020 @ 09:07

    Ryzen 2700X on ASUS ROG Strix X570-E (Bios 1405) Xonar D2X with original Asus driver. Had random reboots on pciex16_3. Swaped the xonar to pciex1_2 and adjusted in the bios "Gen1". Since two days no random reboot. Found out that the xonar and the amd chipset are sharing one IRQ. Greetings Uli


    • CarvedInside25 Jan 2020 @ 14:37

      Thank you for the info. If you can take a screenshot of the Devices Manager with the devices shown by IRQ and send it to me via e-mail or upload it somewhere(imgur,imgbb, etc.).


      • Uli25 Jan 2020 @ 20:13

        Is the IRQ connected with the pciex slot used or with the hardware?


        • CarvedInside26 Jan 2020 @ 03:57

          I moved your comment from a new comment to a reply to the original discussion since it's somewhat related. If you want to add anything that relates to a discussion, please use the REPLY button on the left of the comment you are replying to.

          IRQ are generated by the motherboard. It should change if you change the PCIe slot, but I am not 100% confident of this.
          For your IRQ sharing case, if you want to avoid the IRQ sharing try installing the latest AMD chipset drivers see if the "AMD SATA Controller" is switched to MSI mode (Message signaled interrupts). If that does not do anything you can rollback the driver in Device Mananger for that "AMD SATA Controller" so that it uses the "Standard AHCI SATA-Controller" driver from Microsoft which works in MSI mode.

          If you try any of these things let me know how it goes.


          • Uli26 Jan 2020 @ 11:00

            At first I must explain that I have only 2 pciex slots which can be used for sound- and TV card. The Vega 64 monster is occupying 4 slots as it needs a supporting arm to carry its weight. The sound in pciex1_2 was somehow distorted may because of the IRQ sharing. So I swaped TV and soundcard again so that the xonar is back in pciex16_3. And yes the IRQ's are connected to the used slots. Concerning MSI mode on Guru3D I found a handy tool called "MSI mode utility". I tried to change the Xonar to MSI mode but it seems that the card is not supporting it. Anyway the xonar has its own exclusive IRQ in pciex16_3 which is running in Gen 1 mode. Thats my status in the moment.


            • CarvedInside27 Jan 2020 @ 02:36

              Thank you for the information. It's good to have the confirmation about the IRQ assignment, since I was not really sure how it behaved on these Ryzen motherboards.
              I did not get into more details about the MSI tool as I thought you've already seen what I've written about it in the article I've made about IRQ's.

              I think those distortions where caused by EMI (Electromagnetic interference) from the the video card. Generally you should have the sound card as further away from the GPU as possible, especially when it comes to these high end and high power video cards. If you are concerned about these EMI from the video card or even from the TV tuner, you could make an EMI shield, in your case, only for the back of your sound card (#1, #2). And have the PC connected to a grounded electrical outlet.

              Let us know if you system shows any signs of instability that could be related to the Xonar card.


              • Uli31 Jan 2020 @ 09:21

                From Sunday to Wednesday I thought I was on the winner side but then again I had a random reboot. Then I altered another option in the Bios, it is called PCIEX16_3 4X-2X Switch: I switched from Auto to 2X. (4X is also possible).
                Bios Info: If PCIE device is inserted to PCIEx1_2 (in my case the TV Card) switch PCIEX16_3 to 2x Mode.
                I hope that will help


                • CarvedInside01 Feb 2020 @ 02:43

                  Since you are using the ASUS original drivers, check that GX is disabled in ASUS Audio Center.
                  If you still have reboots, try possible solution 7.


                  • Uli01 Feb 2020 @ 13:14

                    Yesterday I had again an unwanted reboot. I forgot to mention that im running on those drivers by Daniel K without the GX option. I disabled now all recording devices.

                    Update: Damn, reboot hapened again. My last idea is the 1405 mod Bios by Reous



Leave a new commentReply to comment

Comment received.
Your comment may be held for moderation. If it does not show up immediately, please be patient. Comments have to comply with these rules:
  • English language only
  • Don't post insults or threats
  • Try to keep the discussion constructive and informative
  • Don't post questions without doing a search beforehand
  • For replies to individuals regarding the SAME discussion, use Reply to write to that individual. For a NEW issue write a new comment.
  • Make your comment easly readable. Write the product names how they are originally written or at least capitalize their first letter. Write "i" as "I". Add a space after end of a sentence and beginning of another (e.g. ".I" -> ". I").

We've noticed that you're using an AdBlocker

It's not just you, over 66% of our site's visitors are blocking the ads.

Please disable adblock for this website and refresh this page if you:
find the content useful
want us to create more useful content and software
want tech support through the comment section

The ads are placed so that there is minimal interference with page reading. There are no pop-up, pop-under or sticky ads.

Alternatively, you can support us by making a donation.