sprite

529 Comments

  1. Bob cool27 Aug 2021 @ 23:29

    Asus rog stryx 570 with d2x here i can finally install drivers any asus stock or unidriver.
    DOCP must be disabled to install the drivers and avoid bsod,it can be reactivated after the driver installed successfully.

    That did the trick for me no other manipulation was successful before.

    Reply

  2. Ddawg28 Aug 2021 @ 02:59

    Xonar Essence STX and MSI B550 TOMAHAWK did not work together.

    I've tried multiple PCIe slots, disabling HD audio in BIOS, and trying the audio card on another device (it works perfectly). Bummer πŸ™

    Reply

    • CarvedInside29 Aug 2021 @ 23:43

      Can you confirm it's the first version of STX and not the STX II?
      When you say it's not working, what it's happening exactly? Does the card not show up at all, you get BSOD when installing the drivers or BSOD occasionally when the sound is playing?

      Reply

  3. Someone30 Sep 2021 @ 19:41

    Hello, can you please tell me if the ASUS XONAR ESSENCE STX II 5.1 works with the Asus ROG Strix X570-E Gaming ?

    https://rog.asus.com/uk/motherboards/rog-strix/rog-strix-x570-e-gaming-model/

    Thanks πŸ™‚

    Reply

    • Lemmiwinks15 Feb 2022 @ 05:53

      Gonna follow up here because it's taken me days to get it working but I finally have it!!! My MOBO is the slightly newer version that the one you listed, but I think this should do it.

      System:
      Ryzen 5950X
      Asus ROG Strix X570-E Gaming WIFI II - BIOS Version 0309 - Windows 10 Pro Version 21H2
      EVGA RTX 3090
      Xonar Essence STX II

      I was having a terrible issue where just trying to install drivers (of any kind, official or otherwise) for my STX II would cause my system to hard reset. I was able to finally get it by resetting my BIOS to default and then setting the specific PCIE port I had the sound card in to run in GEN 1 mode in the BIOS. Once that happened the drivers would install, however I was still having an issue where if I switched between my headphones and speakers in the GUI, my PC would hard reset. Additionally, opening any program that used my microphone (such as Discord) would also hard reset my PC. No BSOD, simply a 100% hard reset.

      I then disabled my MOBO audio in the BIOS, booted PC, and then opened my sound settings and disabled everything that wasn't the STX II (for both playback and recording). After this, I reset my PC again. Everything booted normally and was then working correctly. Lastly, I went back into the BIOS, returned all my settings to their previous states (excepting the ones I stated above), and then changed the PCIE port to GEN 3 (not sure if this is relevant but I assumed higher = better so I wanted to get it to the highest that would work).

      Everything is now working perfectly as it was before I upgraded to a new MOBO. Feels good man, there is a GOD!!!

      Reply

  4. ozorfis03 Oct 2021 @ 06:38

    Asrock X570 creator + Asus STX II does not work (unstable system). It really is a shame since I liked the card a lot and invested a lot in mods.

    Reply

    • CarvedInside04 Oct 2021 @ 02:01

      Have you tried any of the possible solutions that I've provided, particularly possible solutions 3 and 4?

      Reply

  5. Matt D.11 Oct 2021 @ 20:26

    Xonar DX working perfectly here with Asus drivers on a ASRock B550 Phantom Gaming 4.

    Reply

  6. askeladden25 Oct 2021 @ 20:05

    ASUS Prime X570-P +STX(1) Works perfectly fine here. Been using the combination almost 2 years now. Gaming, music.. you name it. No problems to report.

    Is there any reason to believe i will have issues if i decide to upgrade to STXII?

    Reply

    • CarvedInside25 Oct 2021 @ 22:46

      There is a good chance you will have issues if you go with the STX II. If I where in your situation, I would not upgrade to a STX II card.

      Reply

      • askeladden11 Nov 2021 @ 16:09

        I guess i will find out.. got a good deal for a used card. paid $60. Can always resell if it doesn't work out. Will update with my findings.

        Reply

      • askeladden18 Nov 2021 @ 19:48

        STX II works perfectly fine. No problems to report. Switching outputs etc works as it should. Only difference was that with this card i had to install drivers in unsigned driver mode.

        Reply

        • CarvedInside20 Nov 2021 @ 23:22

          Good to hear. Let us know if the situation changes. FYI, the UNi Xonar drivers ending with a "b" have a valid driver signature for STX II.

          Reply

  7. Snk301 Dec 2021 @ 23:18

    Gigabyte AX370 Gaming 3 BIOS F41 with R5 1600AE and working fine with Xonar DX (W10 21H1 + v1.75a-r3). I was having unbalanced sound issue sometimes, but it's running fine for the last two weeks after I removed HsMgr.exe, anyway, CarvedInside said that when you install driver in "Low DPC Latency", HsMrg.exe process does not run, soo I'm not sure if that really fixed the issue.

    Reply

  8. Matt D.11 Dec 2021 @ 20:29

    Built another computer, this time with an Gigabyte B550 Aorus Elite Ver. 1.0. Xonar DX works perfectly fine with Asus drivers.

    Reply

  9. Lovedrunken19 Dec 2021 @ 19:38

    AsRock Killer x370 working fine with Xonar D1 and PCI Adapter.

    Reply

  10. toffelwurst27 Dec 2021 @ 12:50

    MSI MEG X570 Unify works fine with XONAR DGX running Windows 10 21H1 and original ASUS drivers (Xear3D DS3D - 8.1.8.1823). Want to test Uni drivers soon...

    Reply

  11. Steve15 Jan 2022 @ 15:14

    Some notes. Not super detailed but thought better than nothing.

    Xonar Essence STX I works somewhat with the Asrock X470 Taichi motherboard using the Uni Xonar drivers. It does have issues with occasionally blowing the speakers which is quite painful. Essence STX II does not work with any drivers. Always crashes at driver cleaning (even if its chosen not to do that. Whenever the clicks are heard during the install it crashes the system and restarts).

    Xonar Essence STX II works partially with Asus ROG Strix B550-F. It does have the same blowing of the speakers issue (Randomly an audio source starting causes a high pitched noise thats only fixed with a restart) and occasionally changing audio output (Speakers to headphones) and also something going trough them (Discord upon startup) causes a system crash and reset.

    Next going back to Xonar DGx. Hopefully it won't have any issues.

    Reply

    • CarvedInside18 Jan 2022 @ 15:47

      Did you had these loud high pitch noise issues on a non AMD Ryzen platform with the STX I and STX II cards?
      These loud noise issues might not be caused by the AMD Ryzen motherboards. If that's the case, you might want to look at ASUS Xonar cards and loud white noise issue page for possible solutions and discussions.

      Reply

  12. TechLord07 Feb 2022 @ 17:11

    Hi! I can confirm issues (I've been banging my head for half an year on why my PC is rebooting):
    - Motherboard: Asrock B550M Pro4
    - CPU: tried with R5 3600 and 5600x, same behaviour
    - Sound card: Asus Xonar DSX
    Issue: Random reboot of system even if idle, Windows Event Viewer saying something about WHEA=Logger Issue 18 or something
    Fix:
    a) Manually set PCIe to Gen3 in bios
    b) remove Asus Xonar DSX

    After a or b system is stable.

    Reply

    • CarvedInside07 Feb 2022 @ 20:10

      What's the name of the setting that you've set to Gen3?

      Reply

      • TechLord07 Feb 2022 @ 20:42

        Hi!
        I found the setting in: Bios->Advanced-> AMD PBS-> PCIe/GFX Bus Interface
        In normally is set to AUTO but putting Gen3 fixes my DSX issues.
        Background:
        I had the following specs:
        CPU R5 3600
        GTX 1660 Super
        This system was stable for half an year.
        Next, I managed to get an RTX card and install it. After I swapped the video cards the system started to randomly reboot. Because the RTX was not rebooting other systems I tested it in I started to think about what changes did the GPU swap do to the PC and the first thing that occurred to me was that the GTX was putting the PCI-E in Gen3 mode while the RTX put it in Gen4 mode. So I manually put Gen3 in BIOS and it became stable, 0 issues.
        At that point I started to blame AMD and ASROCK but then I found this AMD forum https://community.amd.com/t5/processors/whea-logger-event-id-18/td-p/266186/page/24 where some guy said his system rebooted because of XONAR D2X so I took out my DSX, put auto (GEN4) in BIOS and running great ever since.
        So Xonars and PCI-E GEN4 is not a good fit....too bad, the DSX is lightyears ahead of the onboard stuff

        Reply

        • CarvedInside08 Feb 2022 @ 10:50

          Thank you for the information. That's interesting, that option is for the first PCIe slot where you put your GPU and that slot is connected to the CPU, on the other hand, the B550 chipset PCIe slots are Gen3 and CPU chipset PCIe uplink is also Gen3.

          I think your report on how the issue was fixed for you fits in the thesis that's something related to the power delivery on the motherboards. Having the GPU PCIe slot to Gen4 requires more power from the motherboard. You can look at what I wrote in possible solution 9 and the linked report for more on this.

          Reply

          • TechLord08 Feb 2022 @ 16:56

            Hi!Hmmm, few comments:
            1. The Asrock B550M Pro4 has 3 PCI-E slots, as follows:
            a) 1x PCI-E X16 Gen4 linked directly to the CPU for the GPU
            b) 1x PCI-E x1 Gen3 linked to the CHIPSET
            c) 1x PCI-E x4 Gen3 linked to the CPU - this is where my DSX was
            I think that the last PCI-E (the slot x4) goes to the CPU because the whole downlink between CPU and chipset is x4 Gen3 so if I put something in the x4 I would eat all the chipset bandwidth (satas, m2,etc). It is also kind of implied in the MB specs page if you look at slots to CPU type relation
            Some of the issues I can think of:
            a) The CPU PCI-E controller or the Motherboard does not like that it has a Gen4 (GPU) and a Gen3 (DSX) running at the same time... to support this I bring the fix that if I put the GPU in Gen3 mode the system is stable
            b) The DSX might send some weird signal via the PCI-E lanes which the CPU does not like...the DSX was created/designed when only PCI-E Gen1 was in place...between Gen1 and Gen4 some things might have changed (even though Gen4 is backwards compatible)
            One thing I can test is to try to put the DSX in the X1 slot which goes to the chipset, maybe the chipset can filter any issue...not sure if possible, might hit the GPU fans

            Reply

            • CarvedInside09 Feb 2022 @ 05:40

              On your motherboard only the first PCIe (x16) slot is connected to the CPU. The other two PCIe slots (x1 and x16) are connected to the B550 chipset. The CPU has another PCIe Gen4 x4 connection that's used for the first M.2 slot. Here you have the Ryzen Zen3 CPU and B550 chipset block diagram. If the 2nd PCIe slot would have been connected to the CPU, the specs would describe it as "2 x PCI Express 4.0 x16 Slots (single at x16 (PCIE1); dual at x8 (PCIE1) / x8 (PCIE3))" or "PCIe(3) Gen4 x4" and list the M.2 slot as Gen3. The way ASRock listed the PCIe slots specs is deliberately to confuse and mislead.

              That being said, there is a small chance that the other chipset PCIe (x1) slot might work slightly different and that may be just enough to not trigger this issue.

              If your try the PCIe x1 slot or find anything else, let us know.

              Reply

  13. Nuggest08 May 2022 @ 12:35

    Managed to get the STX II running with my new built (Gigabyte x570s UD mainboard - Ryzen 9 5900x).
    PC crashed without error code and rebooted during first installation attempt when the "clicking" noise of the stx occurred.

    Updated the bios from F2 to F4a and forced the PCIe port to gen 3. Works without a hitch ever since.

    Reply

  14. freeman220901 Jun 2022 @ 21:32

    Gigabyte B450M DS3H with BIOS f63b, ASUS Xonar Xense, Win 10 21H1 is working fine (normal Asus Audio Center).

    Admin notice: Text lower case corrected.

    Reply

Legend:AdminAuthorFeaturedLinkedOff-topic

Leave a new commentReply to comment

Comment received.
Your comment may be held for moderation. If it does not show up immediately, please be patient. Comments have to comply with these rules:
  • English language only
  • Don't post insults or threats
  • Try to keep the discussion constructive and informative
  • Don't post questions without doing a search beforehand

We've noticed that you're using an AdBlocker

It's not just you, over 66% of our site's visitors are blocking the ads.

Please disable adblock for this website and refresh this page if you:
find the content useful
want us to create more useful content and software
want tech support through the comment section

The ads are placed so that there is minimal interference with page reading. There are no pop-up, pop-under or sticky ads.

Alternatively, you can support us by making a donation.

Close